summaryrefslogtreecommitdiff
path: root/dev-ml/opam
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/opam
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/opam')
-rw-r--r--dev-ml/opam/Manifest4
-rw-r--r--dev-ml/opam/files/stublibs.patch13
-rw-r--r--dev-ml/opam/metadata.xml11
-rw-r--r--dev-ml/opam/opam-1.3.1-r1.ebuild55
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-ml/opam/Manifest b/dev-ml/opam/Manifest
new file mode 100644
index 000000000000..26eeab5cac8a
--- /dev/null
+++ b/dev-ml/opam/Manifest
@@ -0,0 +1,4 @@
+AUX stublibs.patch 591 BLAKE2B 6aca6475f230754bba8822d5181c9bb798004efad8a5656e7f5380d03544f6e67e875b0bc7ccce41ac0262af40961a823f6fd2906433a8c66f53d67d24cb0a5c SHA512 b10fd1ed192d6bba0c893538a6c936d37330f8fc89bfc30f334c5ef1086e4274b989c7ab8e059754d87cbb64897c0657a5ff49add456f83fb035185631bacce4
+DIST opam-1.3.1.tar.gz 669485 BLAKE2B e1aed54175d46f5dd9fd989e56c25657370356e26df6976c01dd089e381291fa04e25da295104f85d513010cd028276d80ebf7a4a77b38f3e089e52f4e64f43a SHA512 d075c9b2c9670d712f29bd2df34b8020da52041fa2bbef599cb54a81f63554507d78bebece45ecf668d3d1d4ed514e4ab88a1d86b64088d283bca7a8e75ae582
+EBUILD opam-1.3.1-r1.ebuild 1075 BLAKE2B 334576f3cb0e1f02c56bf82705c46a437ac7445ce83190165a08f811b57250fcfd21e9e343978d2a084346a4435ce410d9f2c0bb9361939a633b71bd16136822 SHA512 c1576cd46bd94d361eccca0872789b6b29ba066cc4d25f54ef70b3894f7115994c71b8039a9e619dc7ec10f1946446a355cf850f9b63eb06343d6f539f969ac1
+MISC metadata.xml 332 BLAKE2B 5e7949f7babb5f9252545c40f5105d71237189171412662ebe745aa2d93e023a7dad16e3bbae18086c7a0d7891ba349ddee4a5e00f9d8230e5ac1d84643d2489 SHA512 56e886c385af81781aa4ab1c9ead244b35352f521635236d211ef753c8d6eb85e68097fa599b6ff2191d3be91194704dacaff2d3882aceccec82cbfc3d9a8265
diff --git a/dev-ml/opam/files/stublibs.patch b/dev-ml/opam/files/stublibs.patch
new file mode 100644
index 000000000000..3cb61883233a
--- /dev/null
+++ b/dev-ml/opam/files/stublibs.patch
@@ -0,0 +1,13 @@
+Index: opam-1.3.1/src/tools/opam_installer.ml
+===================================================================
+--- opam-1.3.1.orig/src/tools/opam_installer.ml
++++ opam-1.3.1/src/tools/opam_installer.ml
+@@ -312,7 +312,7 @@ let options =
+ let mandir = mk_dir mandir in
+ let libdir = mk_dir libdir in
+ let stubsdir = match mk_dir stubsdir, libdir with
+- | None, Some d -> Some OpamFilename.Op.(d / "stubslibs")
++ | None, Some d -> Some OpamFilename.Op.(d / "stublibs")
+ | d, None | (Some _ as d), _ -> d
+ in
+ let topdir = match mk_dir topdir, libdir with
diff --git a/dev-ml/opam/metadata.xml b/dev-ml/opam/metadata.xml
new file mode 100644
index 000000000000..417bf2d4b393
--- /dev/null
+++ b/dev-ml/opam/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocaml/opam</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/opam/opam-1.3.1-r1.ebuild b/dev-ml/opam/opam-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..57dd504dc707
--- /dev/null
+++ b/dev-ml/opam/opam-1.3.1-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A source-based package manager for OCaml"
+HOMEPAGE="http://opam.ocaml.org/"
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="test"
+
+if [[ ${PV} != 9999 ]]; then
+ SRC_URI="https://github.com/ocaml/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ocaml/opam.git"
+fi
+
+RDEPEND="dev-lang/ocaml:=
+ || ( net-misc/wget net-misc/curl )
+ dev-ml/extlib:=
+ dev-ml/ocaml-re:=
+ dev-ml/ocamlgraph:=
+ dev-ml/cmdliner:=
+ dev-ml/cudf:=
+ >=dev-ml/dose3-5:=
+ dev-ml/uutf:=
+ dev-ml/jsonm:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ test? ( dev-vcs/git )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/stublibs.patch"
+}
+
+src_compile() {
+ emake -j1
+ cd doc
+ emake man
+}
+
+src_test() {
+ EMAIL=foo@bar.com emake -j1 tests
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" OPAMINSTALLER_FLAGS="--prefix=\"${ED}/usr\" --libdir=\"${D}/$(ocamlc -where)\"" libinstall
+}