summaryrefslogtreecommitdiff
path: root/dev-ml/opam-state
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ml/opam-state
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ml/opam-state')
-rw-r--r--dev-ml/opam-state/Manifest3
-rw-r--r--dev-ml/opam-state/metadata.xml11
-rw-r--r--dev-ml/opam-state/opam-state-2.0.7.ebuild36
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-ml/opam-state/Manifest b/dev-ml/opam-state/Manifest
new file mode 100644
index 000000000000..3165716c2fed
--- /dev/null
+++ b/dev-ml/opam-state/Manifest
@@ -0,0 +1,3 @@
+DIST opam-2.0.7.tar.gz 636708 BLAKE2B 2824a5c53f4103c267f99ae10f55df740b3afcc033321e888133817c0e53c4a8fc31738338df3d6d9ff8755987e85ade4a4726be98f77b06b81ffc1476d02c3d SHA512 2ade3998a94333a5a838b55e229ab0c707e678481cae892980b986fb86f39163070a9b7d3e0e87879cd57b91a33bf6a3e15f3786c3510a635e59383782218f1d
+EBUILD opam-state-2.0.7.ebuild 738 BLAKE2B 06a42200b392ee033a9abf9baa3ffd2f9e0e07d486c8f788c86c615ca280e14563f49f3712a09185d704d5aa60ca78dd0ee8ca27cc0f3272cf5215b717e9919b SHA512 9693f5b0919884dd311656677661cc4e17302630c3f04d38b3218cb26e3d0bbc10a96124c7306c9f2c9b2b53490f616f564e7355118652df0d394262a7d015ea
+MISC metadata.xml 319 BLAKE2B f3a6de363afedd8ecf6d5cd898b0ecc0c7da67070f8929f39f6e5395303505e9b2679cd32ba4445f155aa522bc09f5c6bdb09a3941f679c5eb1ff757040f0d40 SHA512 c251d0c83e251b9f20f83be5d67381c562400dc1567a4d3a32b396c309dc669b03f1d7e25e4d953c155d41aeaad07d47a67a2c602855cd45d5c9bb749dfa3b3f
diff --git a/dev-ml/opam-state/metadata.xml b/dev-ml/opam-state/metadata.xml
new file mode 100644
index 000000000000..970e090f0dfd
--- /dev/null
+++ b/dev-ml/opam-state/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocaml/opam</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/opam-state/opam-state-2.0.7.ebuild b/dev-ml/opam-state/opam-state-2.0.7.ebuild
new file mode 100644
index 000000000000..a0a6b6eda7c1
--- /dev/null
+++ b/dev-ml/opam-state/opam-state-2.0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="opam state libraries"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/opam-repository:=
+ dev-ml/re:=
+ dev-ml/opam-file-format:=
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/opam-${PV/_/-}"
+RESTRICT="test"
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9-33)))
+ (release
+ (flags (:standard -warn-error -3-9-33))))
+ EOF
+}