summaryrefslogtreecommitdiff
path: root/dev-ml/opam-repository
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ml/opam-repository
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ml/opam-repository')
-rw-r--r--dev-ml/opam-repository/Manifest3
-rw-r--r--dev-ml/opam-repository/metadata.xml11
-rw-r--r--dev-ml/opam-repository/opam-repository-2.0.7.ebuild37
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-ml/opam-repository/Manifest b/dev-ml/opam-repository/Manifest
new file mode 100644
index 000000000000..4bf4a616a820
--- /dev/null
+++ b/dev-ml/opam-repository/Manifest
@@ -0,0 +1,3 @@
+DIST opam-2.0.7.tar.gz 636708 BLAKE2B 2824a5c53f4103c267f99ae10f55df740b3afcc033321e888133817c0e53c4a8fc31738338df3d6d9ff8755987e85ade4a4726be98f77b06b81ffc1476d02c3d SHA512 2ade3998a94333a5a838b55e229ab0c707e678481cae892980b986fb86f39163070a9b7d3e0e87879cd57b91a33bf6a3e15f3786c3510a635e59383782218f1d
+EBUILD opam-repository-2.0.7.ebuild 755 BLAKE2B 58f55bea8bc596b724fd507a896aa92344bd5c9c1f5221cf14354d061b420863ab6ad416f13c05feb840ea3928cf4e4a0c8805596d202eb28b8b23a8f8f04385 SHA512 224ab1242de083f3c5a24242c0f8c418c5fead9f11bd7fdd1f81d700a7a089d5baab8f14c03b9ab15ed57b8e16fa0ded4184d73f10a7d1a68894f13e086a1102
+MISC metadata.xml 319 BLAKE2B f3a6de363afedd8ecf6d5cd898b0ecc0c7da67070f8929f39f6e5395303505e9b2679cd32ba4445f155aa522bc09f5c6bdb09a3941f679c5eb1ff757040f0d40 SHA512 c251d0c83e251b9f20f83be5d67381c562400dc1567a4d3a32b396c309dc669b03f1d7e25e4d953c155d41aeaad07d47a67a2c602855cd45d5c9bb749dfa3b3f
diff --git a/dev-ml/opam-repository/metadata.xml b/dev-ml/opam-repository/metadata.xml
new file mode 100644
index 000000000000..970e090f0dfd
--- /dev/null
+++ b/dev-ml/opam-repository/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocaml/opam</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/opam-repository/opam-repository-2.0.7.ebuild b/dev-ml/opam-repository/opam-repository-2.0.7.ebuild
new file mode 100644
index 000000000000..11652c5bbcb6
--- /dev/null
+++ b/dev-ml/opam-repository/opam-repository-2.0.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="opam repository libraries"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/opam-format:=
+ dev-ml/re:=
+ dev-ml/dose3:=
+ dev-ml/opam-file-format:=
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/opam-${PV/_/-}"
+RESTRICT="test"
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9-33)))
+ (release
+ (flags (:standard -warn-error -3-9-33))))
+ EOF
+}