summaryrefslogtreecommitdiff
path: root/dev-ml/opam-installer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ml/opam-installer
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ml/opam-installer')
-rw-r--r--dev-ml/opam-installer/Manifest3
-rw-r--r--dev-ml/opam-installer/metadata.xml11
-rw-r--r--dev-ml/opam-installer/opam-installer-2.0.7.ebuild41
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-ml/opam-installer/Manifest b/dev-ml/opam-installer/Manifest
new file mode 100644
index 000000000000..e23f8c03696f
--- /dev/null
+++ b/dev-ml/opam-installer/Manifest
@@ -0,0 +1,3 @@
+DIST opam-full-2.0.7.tar.gz 7929123 BLAKE2B 100acc2c31e97e47b0b584f3a153283593351d49d5e9cdaca42fdcc025b135d9538bd327927950e7e0972b20f561a0ee3d1d1b5b4b87e1e6af31761e311081e7 SHA512 670af4935bba0679c65f6592b7a52b1d429b604eb261e40b13cf72312aeb0bab0c5a76829a555fc5379a0371c352692cbabc46b460fcd9bf32b3cfebdaeceb81
+EBUILD opam-installer-2.0.7.ebuild 979 BLAKE2B 02fcbc0388aec4c5898b065b0418d65cf30903497a0b9ea676a49c1d3ae6b1f6282ab1d525a965d6ac6a5910a79033cabd8b69ccf872e92f40d8c929cc2eb59e SHA512 484bfccf97b0392792f71cffad42222a37a7ca7e351c3ec8aa7fa54fa04a2f8074fa26155c0f2619d4a48bceb9672c27c33f15621d12ac2d06a87d7dcfc6f682
+MISC metadata.xml 319 BLAKE2B f3a6de363afedd8ecf6d5cd898b0ecc0c7da67070f8929f39f6e5395303505e9b2679cd32ba4445f155aa522bc09f5c6bdb09a3941f679c5eb1ff757040f0d40 SHA512 c251d0c83e251b9f20f83be5d67381c562400dc1567a4d3a32b396c309dc669b03f1d7e25e4d953c155d41aeaad07d47a67a2c602855cd45d5c9bb749dfa3b3f
diff --git a/dev-ml/opam-installer/metadata.xml b/dev-ml/opam-installer/metadata.xml
new file mode 100644
index 000000000000..970e090f0dfd
--- /dev/null
+++ b/dev-ml/opam-installer/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocaml/opam</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/opam-installer/opam-installer-2.0.7.ebuild b/dev-ml/opam-installer/opam-installer-2.0.7.ebuild
new file mode 100644
index 000000000000..276428f96786
--- /dev/null
+++ b/dev-ml/opam-installer/opam-installer-2.0.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# We are opam
+OPAM_INSTALLER_DEP=" "
+OPAM_SKIP_VALIDATION=yes
+
+inherit opam
+
+DESCRIPTION="Core installer for opam packages"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/releases/download/${PV}/opam-full-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-4.02.3"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/opam-full-${PV/_/-}"
+OPAM_INSTALLER="${S}/opam-installer"
+
+src_configure() {
+ econf \
+ --prefix="${EPREFIX}/usr" \
+ --with-mccs \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --mandir="${EPREFIX}/usr/share/man"
+}
+
+src_compile() {
+ sed -e 's/DUNE = .*$/DUNE = /' -i Makefile.config
+ emake lib-ext
+ #passing -jX to the dune build leads to errors
+ #see: https://github.com/ocaml/opam/issues/3585
+ emake DUNE_PROMOTE_ARG="" -j1
+}