summaryrefslogtreecommitdiff
path: root/dev-ml/opam-installer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-ml/opam-installer
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-ml/opam-installer')
-rw-r--r--dev-ml/opam-installer/Manifest4
-rw-r--r--dev-ml/opam-installer/opam-installer-2.0.7-r1.ebuild46
-rw-r--r--dev-ml/opam-installer/opam-installer-2.0.8-r1.ebuild (renamed from dev-ml/opam-installer/opam-installer-2.0.7.ebuild)13
3 files changed, 56 insertions, 7 deletions
diff --git a/dev-ml/opam-installer/Manifest b/dev-ml/opam-installer/Manifest
index d36893a9b76d..5a6de2524479 100644
--- a/dev-ml/opam-installer/Manifest
+++ b/dev-ml/opam-installer/Manifest
@@ -1,3 +1,5 @@
DIST opam-full-2.0.7.tar.gz 7929123 BLAKE2B 100acc2c31e97e47b0b584f3a153283593351d49d5e9cdaca42fdcc025b135d9538bd327927950e7e0972b20f561a0ee3d1d1b5b4b87e1e6af31761e311081e7 SHA512 670af4935bba0679c65f6592b7a52b1d429b604eb261e40b13cf72312aeb0bab0c5a76829a555fc5379a0371c352692cbabc46b460fcd9bf32b3cfebdaeceb81
-EBUILD opam-installer-2.0.7.ebuild 996 BLAKE2B ed78f3fe94aac3691ce8506709ccf649debeb6171068644062c74a561c3642ad1fbc9dfffcfc168b2f449984b86d22baeecf5e82dd957af360c87abe29131b6f SHA512 41bb0cb0320b9518974403bca3a3dc44db6056e8e3a12d4e85245293f6a40f89aea805ab6a7e0268049adce012a460e36d970cd01cc61ea179faaa4e29775993
+DIST opam-full-2.0.8.tar.gz 8006252 BLAKE2B 26348bdbb8bdc2fbf9d736286c1f4134ce065e8c15e34d51c8d2c6e5338fd6db089df38a19b07cde70770724fc4cc3dbd9e7d75628e5435ca8a2f8c0d4d3f2f0 SHA512 f08893ad0c1e124368168f28dcb5c3293e443da712d7b12db432c21ff72f7e1440bcc7156f49661d286360a16dcd166d3d02ecdebf8b1cda7c7df2b22e48f80f
+EBUILD opam-installer-2.0.7-r1.ebuild 1041 BLAKE2B 9c89e154ba44b46b13ee43a359965e8b9a49c89971fc7d255763cb7f7117dda2e5efcc05328ef9535e8656555b6cc8f4f9f824cb66afcdbc81182c085d8a0dcd SHA512 64ea51c7f4c478a44e6d53f1502c0af6d3af1e6e3455f101a18c4004a5076211974da00387456939dc5b893e08faff1db5dce404459f8c86777a3ebd9af524e5
+EBUILD opam-installer-2.0.8-r1.ebuild 1035 BLAKE2B 3fed226230b158fe9a8f8f5c206f0acfde77417c3c3d963c36f28889629291fb6bbb63f732861bee3b4f84ff8cd7ee6650f76a20d374aaefef8978a622920325 SHA512 f0f719bfd2f34d8f6c7f8a464da712ba99a09927d71a893d7e600b4156c948b01dc980666d60833dd6dd6c5d5869389415f98a5f79708ec77263fbab783dbc51
MISC metadata.xml 412 BLAKE2B 3cd375059a5716aba5f14f8004970adb55bbec02cf911cc5739475a80789c86ab6d27f192e4757191be8e914e61db531b330695eba224e81273e351d507bd57b SHA512 6119e7d8b9cf779ac2070b8cbe9820849fa80542e86b353d0cab9c60bca6e5d122a1e4f57a75f3189058587e9e8c7d8c5f37e5d4a22395506c437f411df1c4e4
diff --git a/dev-ml/opam-installer/opam-installer-2.0.7-r1.ebuild b/dev-ml/opam-installer/opam-installer-2.0.7-r1.ebuild
new file mode 100644
index 000000000000..87658e669be1
--- /dev/null
+++ b/dev-ml/opam-installer/opam-installer-2.0.7-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# We are opam
+OPAM_INSTALLER_DEP=" "
+OPAM_SKIP_VALIDATION=yes
+
+inherit opam
+
+DESCRIPTION="Core installer for opam packages"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/releases/download/${PV}/opam-full-${PV}.tar.gz"
+S="${WORKDIR}/opam-full-${PV/_/-}"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02.3
+ dev-ml/cmdliner:=
+ ~dev-ml/opam-format-${PV}
+"
+DEPEND="${RDEPEND}
+ dev-ml/findlib"
+
+OPAM_INSTALLER="${S}/opam-installer"
+
+src_configure() {
+ econf \
+ --prefix="${EPREFIX}/usr" \
+ --with-mccs \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --mandir="${EPREFIX}/usr/share/man"
+}
+
+src_compile() {
+ sed -e 's/DUNE = .*$/DUNE = /' -i Makefile.config
+ emake lib-ext
+ #passing -jX to the dune build leads to errors
+ #see: https://github.com/ocaml/opam/issues/3585
+ emake DUNE_PROMOTE_ARG="" -j1
+}
diff --git a/dev-ml/opam-installer/opam-installer-2.0.7.ebuild b/dev-ml/opam-installer/opam-installer-2.0.8-r1.ebuild
index 59f744994a07..369358c1de01 100644
--- a/dev-ml/opam-installer/opam-installer-2.0.7.ebuild
+++ b/dev-ml/opam-installer/opam-installer-2.0.8-r1.ebuild
@@ -6,25 +6,26 @@ EAPI=7
# We are opam
OPAM_INSTALLER_DEP=" "
OPAM_SKIP_VALIDATION=yes
-
inherit opam
DESCRIPTION="Core installer for opam packages"
HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
SRC_URI="https://github.com/ocaml/opam/releases/download/${PV}/opam-full-${PV}.tar.gz"
+S="${WORKDIR}/opam-full-${PV/_/-}"
+OPAM_INSTALLER="${S}/opam-installer"
LICENSE="LGPL-2.1"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE=""
-RDEPEND=">=dev-lang/ocaml-4.02.3"
+RDEPEND="
+ >=dev-lang/ocaml-4.02.3
+ dev-ml/cmdliner:=
+ ~dev-ml/opam-format-${PV}
+"
DEPEND="${RDEPEND}
dev-ml/findlib"
-S="${WORKDIR}/opam-full-${PV/_/-}"
-OPAM_INSTALLER="${S}/opam-installer"
-
src_configure() {
econf \
--prefix="${EPREFIX}/usr" \