summaryrefslogtreecommitdiff
path: root/dev-ml/opam-installer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /dev-ml/opam-installer
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'dev-ml/opam-installer')
-rw-r--r--dev-ml/opam-installer/Manifest1
-rw-r--r--dev-ml/opam-installer/opam-installer-2.0.8-r2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/opam-installer/Manifest b/dev-ml/opam-installer/Manifest
index 964e69169a45..f561d2a100b7 100644
--- a/dev-ml/opam-installer/Manifest
+++ b/dev-ml/opam-installer/Manifest
@@ -1,3 +1,4 @@
DIST opam-full-2.0.8.tar.gz 8006252 BLAKE2B 26348bdbb8bdc2fbf9d736286c1f4134ce065e8c15e34d51c8d2c6e5338fd6db089df38a19b07cde70770724fc4cc3dbd9e7d75628e5435ca8a2f8c0d4d3f2f0 SHA512 f08893ad0c1e124368168f28dcb5c3293e443da712d7b12db432c21ff72f7e1440bcc7156f49661d286360a16dcd166d3d02ecdebf8b1cda7c7df2b22e48f80f
EBUILD opam-installer-2.0.8-r1.ebuild 1029 BLAKE2B 53066e7d4fe28f77ae2cbc1a1eb3056a60d04ada7eb72c0589498815c8ad3937ef6335b73a675bcf7060c6bf85534b3b497b55ac782c1f7a0d3e32537c1489cd SHA512 df08f41985fd16842021dc0e5c8a361a1d8376d1b716f3fb2aff8bdc007ff311ba51844894325e76657a688a03021fe7360c9522ac6f41231ef499de214d469e
+EBUILD opam-installer-2.0.8-r2.ebuild 1020 BLAKE2B a2b8afb4a80a772b812f7394aef05b7d1d8a30c23c8e6f8fc9d6d46de38b8389e8fe975be391f620f94586e459712c5522289bf74b1aee15a9e0a9da1a28404c SHA512 e8a63747de673e5fae11313803192c585d94e91c5d99eb36f8816013e905c305a5bfc21833a40f9291670201288aabe427454d4731d609e6702a891876925717
MISC metadata.xml 412 BLAKE2B 3cd375059a5716aba5f14f8004970adb55bbec02cf911cc5739475a80789c86ab6d27f192e4757191be8e914e61db531b330695eba224e81273e351d507bd57b SHA512 6119e7d8b9cf779ac2070b8cbe9820849fa80542e86b353d0cab9c60bca6e5d122a1e4f57a75f3189058587e9e8c7d8c5f37e5d4a22395506c437f411df1c4e4
diff --git a/dev-ml/opam-installer/opam-installer-2.0.8-r2.ebuild b/dev-ml/opam-installer/opam-installer-2.0.8-r2.ebuild
new file mode 100644
index 000000000000..fa67d1f64afb
--- /dev/null
+++ b/dev-ml/opam-installer/opam-installer-2.0.8-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# We are opam
+OPAM_INSTALLER_DEP=" "
+OPAM_SKIP_VALIDATION=yes
+inherit opam
+
+DESCRIPTION="Core installer for opam packages"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/releases/download/${PV}/opam-full-${PV}.tar.gz"
+S="${WORKDIR}/opam-full-${PV/_/-}"
+OPAM_INSTALLER="${S}/opam-installer"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02.3
+ dev-ml/cmdliner:=
+ ~dev-ml/opam-format-${PV}
+"
+DEPEND="${RDEPEND}
+ dev-ml/findlib"
+
+src_configure() {
+ econf \
+ --prefix="${EPREFIX}/usr" \
+ --with-mccs \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --mandir="${EPREFIX}/usr/share/man"
+}
+
+src_compile() {
+ sed -e 's/DUNE = .*$/DUNE = /' -i Makefile.config
+ #passing -jX to the dune build leads to errors
+ #see: https://github.com/ocaml/opam/issues/3585
+ emake DUNE_PROMOTE_ARG="" -j1
+}