summaryrefslogtreecommitdiff
path: root/dev-ml/opam-file-format
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/opam-file-format
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/opam-file-format')
-rw-r--r--dev-ml/opam-file-format/Manifest3
-rw-r--r--dev-ml/opam-file-format/metadata.xml11
-rw-r--r--dev-ml/opam-file-format/opam-file-format-2.0.0_beta3.ebuild29
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/opam-file-format/Manifest b/dev-ml/opam-file-format/Manifest
new file mode 100644
index 000000000000..26ec992172b6
--- /dev/null
+++ b/dev-ml/opam-file-format/Manifest
@@ -0,0 +1,3 @@
+DIST opam-file-format-2.0.0_beta3.tar.gz 7654 SHA256 522773503b30ff755d04c4e11efb4657e21ac59499da270ef8040d88b4371b59 SHA512 7f4989711e4dc183086b6dccc512ecfe78bfbbd98af954560d5a2c945b8b32416f3a01902203ef78932451cd99a5c1b1571edf70581bd14a2a94e32f5d4dd818 WHIRLPOOL fef711e436ca84312a3054694e8bcb0eb75011b750f8ca1cf31fa77e11d232427f4ee03dde0459cdbd9b9ae607542f0c9e35de9eddf9b63a62e858f243ed395a
+EBUILD opam-file-format-2.0.0_beta3.ebuild 671 SHA256 5513533a09fddfea4067aabf9ed263501ea98fed8270e223154321c39e2d686a SHA512 61ecff19fef0cbcaa2b52cecb2b0f573964c528f0eb8977fb433da89783897a98f8a0f396366282c3ec3e37b00264d4fff0389fc07f96c1834a2dd76a34d13a0 WHIRLPOOL 4f79b66394bd5c470a39f6c6e8ba25472023d63bf72b4c9a3634c1882d0913e6db613f03f9ee8a1cdfc23393f355deb12b687e48040e675c4e525741a7cfeccf
+MISC metadata.xml 344 SHA256 dbbd08081c2a44d8369c212c521059d2dc32a10497ddeb900dbd32c9fef56251 SHA512 2648f0433f04d250e652f6fd0dff4ced963d37641100071f64f1b0c4301d46dafae08bc44ae2ed82d9099b0abc44bb3165ed6f59160fea53f6b4233d26648f01 WHIRLPOOL ec210c5b908f48e83f0834274be310699583f4c7da7448a8b709f7e25b91d770629c8696cb7d6db6db15c2373dcf31bbe211481f7d26e815b253c6827a6863fe
diff --git a/dev-ml/opam-file-format/metadata.xml b/dev-ml/opam-file-format/metadata.xml
new file mode 100644
index 000000000000..6c62d17c464e
--- /dev/null
+++ b/dev-ml/opam-file-format/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocaml/opam-file-format</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/opam-file-format/opam-file-format-2.0.0_beta3.ebuild b/dev-ml/opam-file-format/opam-file-format-2.0.0_beta3.ebuild
new file mode 100644
index 000000000000..e932f300db77
--- /dev/null
+++ b/dev-ml/opam-file-format/opam-file-format-2.0.0_beta3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+MY_PV="${PV/_beta/-beta}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DESCRIPTION="Parser and printer for the opam file syntax"
+HOMEPAGE="https://github.com/ocaml/opam-file-format"
+SRC_URI="https://github.com/ocaml/opam-file-format/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="dev-lang/ocaml:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake byte $(usex ocamlopt native "")
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="$(ocamlc -where)" install
+}