summaryrefslogtreecommitdiff
path: root/dev-ml/opam-file-format/opam-file-format-2.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /dev-ml/opam-file-format/opam-file-format-2.1.3.ebuild
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'dev-ml/opam-file-format/opam-file-format-2.1.3.ebuild')
-rw-r--r--dev-ml/opam-file-format/opam-file-format-2.1.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/opam-file-format/opam-file-format-2.1.3.ebuild b/dev-ml/opam-file-format/opam-file-format-2.1.3.ebuild
new file mode 100644
index 000000000000..fe3328205eeb
--- /dev/null
+++ b/dev-ml/opam-file-format/opam-file-format-2.1.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+MY_PV="${PV/_beta/-beta}"
+MY_PV="${MY_PV/_rc/-rc}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DESCRIPTION="Parser and printer for the opam file syntax"
+HOMEPAGE="https://github.com/ocaml/opam-file-format"
+SRC_URI="https://github.com/ocaml/opam-file-format/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-ml/alcotest )"