summaryrefslogtreecommitdiff
path: root/dev-ml/opam-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
commitf4fc10428424904caf2035cffc442195cb088b2c (patch)
tree72f320d5963e55586cfdeed2b14c72b8191b6327 /dev-ml/opam-core
parentfbd9734cedfe790955100b8e4ab3613457d77b1a (diff)
gentoo resync : 28.07.2021
Diffstat (limited to 'dev-ml/opam-core')
-rw-r--r--dev-ml/opam-core/Manifest2
-rw-r--r--dev-ml/opam-core/opam-core-2.0.9.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/opam-core/Manifest b/dev-ml/opam-core/Manifest
index c5326ed5d233..849351f5c34e 100644
--- a/dev-ml/opam-core/Manifest
+++ b/dev-ml/opam-core/Manifest
@@ -1,3 +1,5 @@
DIST opam-2.0.8.tar.gz 643221 BLAKE2B 66510a18285f315fe95665e8ba2f334dd44211c716543cdc25f2951a7dfe537f115981046e5963fd08deea4c76f5672fa7cf8e7af2274a713a3165bdd0bac8c2 SHA512 14737dc994be2c54dfeaf2658d3713178033e1bc2b4b845a58b4bfc118bbbf12b502924add0ae32b4b2b6c1944462e5ee7143df3de362d9ee39573249d013bc9
+DIST opam-2.0.9.tar.gz 644429 BLAKE2B d96ee79685a8ee8ff82c7570a747c80e38d86e513736a27904a4e471d1eaf432db72998251ac786cb8fbf1ad425fff42b772c5d26934e0929aae75c0946d4659 SHA512 0d8ee19ac0f3df9de4fd9cfa8daab1f7228f090f5e2e7e26bedf24d8c2ab377aade95048f2d7cd9ee9dbbe738729e26dc99f41f730fa2252df74953362464a22
EBUILD opam-core-2.0.8-r1.ebuild 880 BLAKE2B 4cdae8b13b22234fc9628ba3816a5382940201bb6a416766dc0ed1bc096f79fa5ed3d4601547eb83a9655c183a5aa52703e5dc6b068558e0ab83492782c95f6a SHA512 9097d88ac2615449b25a39dde43ae0b61b67bada0f14b2e51071dee777e23b81c7db2872e814e06f44a625bc1d9dcbff27edac87b002f3496ce996dba37696a1
+EBUILD opam-core-2.0.9.ebuild 886 BLAKE2B 46d8727976c104e28523732be20be6b7befde9a3becf3be12e41fde5ff0b6e93d9dfd01cb1536245bb86a8ba2d8864f08fdb4bfb4de54523851fc6fd43366398 SHA512 be4693a07a8c5d52150a175e20ca22f2e441c782ed94dfab55d6df7fa3be78cf699cb6e66a9f9a548c33706a8fdad74047c9c109b90000a4c85fbbd74e3f0d7e
MISC metadata.xml 412 BLAKE2B 3cd375059a5716aba5f14f8004970adb55bbec02cf911cc5739475a80789c86ab6d27f192e4757191be8e914e61db531b330695eba224e81273e351d507bd57b SHA512 6119e7d8b9cf779ac2070b8cbe9820849fa80542e86b353d0cab9c60bca6e5d122a1e4f57a75f3189058587e9e8c7d8c5f37e5d4a22395506c437f411df1c4e4
diff --git a/dev-ml/opam-core/opam-core-2.0.9.ebuild b/dev-ml/opam-core/opam-core-2.0.9.ebuild
new file mode 100644
index 000000000000..63cab62e8277
--- /dev/null
+++ b/dev-ml/opam-core/opam-core-2.0.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# We are opam
+OPAM_INSTALLER_DEP=" "
+inherit opam
+
+DESCRIPTION="Core libraries for opam"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+S="${WORKDIR}/opam-${PV}"
+OPAM_INSTALLER="${S}/opam-installer"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ dev-ml/ocamlgraph:=
+ dev-ml/re:=
+ dev-ml/opam-file-format:=
+ dev-ml/cmdliner:=
+"
+DEPEND="${RDEPEND}
+ <=dev-ml/dune-2.9
+ dev-ml/cppo"
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9)))
+ (release
+ (flags (:standard -warn-error -3-9))))
+ EOF
+}
+
+src_compile() {
+ emake -j1 opam-installer
+ emake -j1 ${PN}.install
+}