summaryrefslogtreecommitdiff
path: root/dev-ml/opam-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ml/opam-core
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ml/opam-core')
-rw-r--r--dev-ml/opam-core/Manifest3
-rw-r--r--dev-ml/opam-core/metadata.xml11
-rw-r--r--dev-ml/opam-core/opam-core-2.0.7.ebuild45
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-ml/opam-core/Manifest b/dev-ml/opam-core/Manifest
new file mode 100644
index 000000000000..87bba10d765f
--- /dev/null
+++ b/dev-ml/opam-core/Manifest
@@ -0,0 +1,3 @@
+DIST opam-2.0.7.tar.gz 636708 BLAKE2B 2824a5c53f4103c267f99ae10f55df740b3afcc033321e888133817c0e53c4a8fc31738338df3d6d9ff8755987e85ade4a4726be98f77b06b81ffc1476d02c3d SHA512 2ade3998a94333a5a838b55e229ab0c707e678481cae892980b986fb86f39163070a9b7d3e0e87879cd57b91a33bf6a3e15f3786c3510a635e59383782218f1d
+EBUILD opam-core-2.0.7.ebuild 868 BLAKE2B 95450353248ac25ae9fa03c5f1f37ace1615dbe7c861011e906005835870e83a513b75b49a1bea8b48f2934439452695caea70bb9f224f75e4d28da31e3861ca SHA512 46dde7182f1ab6c0bd52368f158ec7a4038d3cc3b5b4ac7ac9486fe0f7a4bc02cf6ef5c61a855d8d17bed27e2acba6d3f0c5d463e10e6471f10c23a664c3bfe3
+MISC metadata.xml 319 BLAKE2B f3a6de363afedd8ecf6d5cd898b0ecc0c7da67070f8929f39f6e5395303505e9b2679cd32ba4445f155aa522bc09f5c6bdb09a3941f679c5eb1ff757040f0d40 SHA512 c251d0c83e251b9f20f83be5d67381c562400dc1567a4d3a32b396c309dc669b03f1d7e25e4d953c155d41aeaad07d47a67a2c602855cd45d5c9bb749dfa3b3f
diff --git a/dev-ml/opam-core/metadata.xml b/dev-ml/opam-core/metadata.xml
new file mode 100644
index 000000000000..970e090f0dfd
--- /dev/null
+++ b/dev-ml/opam-core/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocaml/opam</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/opam-core/opam-core-2.0.7.ebuild b/dev-ml/opam-core/opam-core-2.0.7.ebuild
new file mode 100644
index 000000000000..a6adc1400f93
--- /dev/null
+++ b/dev-ml/opam-core/opam-core-2.0.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# We are opam
+OPAM_INSTALLER_DEP=" "
+
+inherit opam
+
+DESCRIPTION="Core libraries for opam"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-ml/ocamlgraph:=
+ dev-ml/re:=
+ dev-ml/opam-file-format:=
+ dev-ml/cmdliner:=
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/opam-${PV/_/-}"
+OPAM_INSTALLER="${S}/opam-installer"
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9)))
+ (release
+ (flags (:standard -warn-error -3-9))))
+ EOF
+}
+
+src_compile() {
+ emake -j1 opam-installer
+ emake -j1 ${PN}.install
+}