summaryrefslogtreecommitdiff
path: root/dev-ml/odoc-parser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-21 13:54:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-21 13:54:09 +0000
commit454de691f3543d47dc89cd0b137eaa9ea4640cd3 (patch)
tree90ec469ff7d2e1b1fac0b0f98f32d49dacb30278 /dev-ml/odoc-parser
parente393c0503a79342594a61547dc43f80f8bcc086e (diff)
gentoo auto-resync : 21:12:2022 - 13:54:08
Diffstat (limited to 'dev-ml/odoc-parser')
-rw-r--r--dev-ml/odoc-parser/Manifest3
-rw-r--r--dev-ml/odoc-parser/metadata.xml17
-rw-r--r--dev-ml/odoc-parser/odoc-parser-2.0.0.ebuild26
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/odoc-parser/Manifest b/dev-ml/odoc-parser/Manifest
new file mode 100644
index 000000000000..5339d38d4026
--- /dev/null
+++ b/dev-ml/odoc-parser/Manifest
@@ -0,0 +1,3 @@
+DIST odoc-parser-2.0.0.tbz 34826 BLAKE2B 0d167fa7d768dfac3b45740707b0a84d300999ef4334ade70286675d906cd7d8c70fcd27e563fb0ab4450f6a0ff8097884af267b376b51e7a91ccfbecb8ac06c SHA512 d2bffa3e9f30471045682e390dcee7a2c1caf3831bca4bd57c16939e782c2e23434e6f1c9887580a1804800b3629ef4c4311a9d418fca5a939f324650d54006e
+EBUILD odoc-parser-2.0.0.ebuild 539 BLAKE2B 5988b2af483221657d38abc71bb409cbc9716ea636a871401d2392269f406d54d7ba65f8f8d7056543f6f8bdc913dde0437701b46bfbd1d1d83bd8c3be761e2c SHA512 ea55d6b39244166f72e2844abc3dd79e93a5ee4ed1d0619f0b9038d8dcc08fc63870732a09f12b96ba69d7011f094b1035e38471af92500c73715d131fcc4671
+MISC metadata.xml 601 BLAKE2B 18f8ae412797bedb9b3d12ebefa7da5c7fefb00181e0c9392cc2f62ab76c2ad4153392c903a6a2221e208b0916fc9d727d840b09dcce3278f1985c6b0b968022 SHA512 bfd7ea44b990f8e20829b4b6a7a64e49bde353c0d4158ff95273c672fd803429c3b81c2c926f9c1a12d433ea704a757f6d9eb520512e074d83cd52bf257ff817
diff --git a/dev-ml/odoc-parser/metadata.xml b/dev-ml/odoc-parser/metadata.xml
new file mode 100644
index 000000000000..c62c1cd9bcf5
--- /dev/null
+++ b/dev-ml/odoc-parser/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription>
+ Odoc_parser is a library for parsing the contents of OCaml
+ documentation comments, formatted using 'odoc' syntax, an extension
+ of the language understood by ocamldoc.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/ocaml-doc/odoc-parser/issues/</bugs-to>
+ <remote-id type="github">ocaml-doc/odoc-parser</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/odoc-parser/odoc-parser-2.0.0.ebuild b/dev-ml/odoc-parser/odoc-parser-2.0.0.ebuild
new file mode 100644
index 000000000000..70381f8c32d2
--- /dev/null
+++ b/dev-ml/odoc-parser/odoc-parser-2.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Parser for ocaml documentation comments"
+HOMEPAGE="https://github.com/ocaml-doc/odoc-parser"
+SRC_URI="https://github.com/ocaml-doc/odoc-parser/releases/download/${PV}/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/astring:=
+ dev-ml/result:=
+ dev-ml/camlp-streams:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? (
+ dev-ml/ppx_expect
+)"