summaryrefslogtreecommitdiff
path: root/dev-ml/ocsigen-toolkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocsigen-toolkit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocsigen-toolkit')
-rw-r--r--dev-ml/ocsigen-toolkit/Manifest4
-rw-r--r--dev-ml/ocsigen-toolkit/metadata.xml11
-rw-r--r--dev-ml/ocsigen-toolkit/ocsigen-toolkit-1.0.0.ebuild46
-rw-r--r--dev-ml/ocsigen-toolkit/ocsigen-toolkit-9999.ebuild46
4 files changed, 107 insertions, 0 deletions
diff --git a/dev-ml/ocsigen-toolkit/Manifest b/dev-ml/ocsigen-toolkit/Manifest
new file mode 100644
index 000000000000..3c1d525cdf9f
--- /dev/null
+++ b/dev-ml/ocsigen-toolkit/Manifest
@@ -0,0 +1,4 @@
+DIST ocsigen-toolkit-1.0.0.tar.gz 69175 BLAKE2B f23dd64a8f8a9c735db3bfd3d60cfe6306354a208fb4b1ee384271a0f8b2fc120afcaa522d1432553ebba90c80639a5980c09c820c6063cbb093998814520410 SHA512 4776dcceef822ac63fd6d57ce05e870f726c1e1d137bab239b8558acb4ef55f97b847825f621414334b01d30c066ea986d2b8180b80a09719b5b76cb3bb69a20
+EBUILD ocsigen-toolkit-1.0.0.ebuild 1006 BLAKE2B 07c32cb76fe6b0123854c77b712c373058b61d75dc8e0557fcfe1094487edeba70ce8cc87eab994ace4ed7113e77187b43401a91db96baa835113ecb072014d7 SHA512 841c534ab057cba641f0b84bf7884a31c147c054944bb668d71b64711466f1dcdd0057f94627e5ca58e9d066524c5f67e9f6e99be587e15df68fa0b751fd07de
+EBUILD ocsigen-toolkit-9999.ebuild 1006 BLAKE2B 07c32cb76fe6b0123854c77b712c373058b61d75dc8e0557fcfe1094487edeba70ce8cc87eab994ace4ed7113e77187b43401a91db96baa835113ecb072014d7 SHA512 841c534ab057cba641f0b84bf7884a31c147c054944bb668d71b64711466f1dcdd0057f94627e5ca58e9d066524c5f67e9f6e99be587e15df68fa0b751fd07de
+MISC metadata.xml 335 BLAKE2B 4f472730256d947ab906c7a69b083439a9d133588c787c5d1d72540d45da38a303d72bb49f24ac0934e2d687614346ba18d4c52ee89f7c144a9b1d066b5d5398 SHA512 1f58da3a51d2b563e3f9ce3b27370163c3604c6dc281824e62e2f6585b59cb93c74be809bc73498b80738df71dddd38d45ecd33fae3811f18fda96411e76af1c
diff --git a/dev-ml/ocsigen-toolkit/metadata.xml b/dev-ml/ocsigen-toolkit/metadata.xml
new file mode 100644
index 000000000000..5539bc3ee579
--- /dev/null
+++ b/dev-ml/ocsigen-toolkit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocsigen/ocsigen-toolkit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocsigen-toolkit/ocsigen-toolkit-1.0.0.ebuild b/dev-ml/ocsigen-toolkit/ocsigen-toolkit-1.0.0.ebuild
new file mode 100644
index 000000000000..9a99adeda85b
--- /dev/null
+++ b/dev-ml/ocsigen-toolkit/ocsigen-toolkit-1.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib opam
+
+DESCRIPTION="User interface widgets for Ocsigen applications"
+HOMEPAGE="https://github.com/ocsigen/ocsigen-toolkit"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt debug"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ocsigen/ocsigen-toolkit"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ocsigen/ocsigen-toolkit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]
+ >dev-ml/js_of_ocaml-2.7:=
+ >=dev-ml/eliom-5.1:=[ppx]
+ dev-ml/ppx_deriving:=
+ dev-ml/calendar:=
+ dev-ml/lwt:="
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake \
+ DEBUG="$(usex debug yes no)" \
+ NATIVE="$(usex ocamlopt yes no)" \
+ all
+}
+
+src_install() {
+ findlib_src_preinst
+ OCAMLPATH="${OCAMLFIND_DESTDIR}" emake install
+ opam_src_install
+ dodoc README.md
+}
diff --git a/dev-ml/ocsigen-toolkit/ocsigen-toolkit-9999.ebuild b/dev-ml/ocsigen-toolkit/ocsigen-toolkit-9999.ebuild
new file mode 100644
index 000000000000..9a99adeda85b
--- /dev/null
+++ b/dev-ml/ocsigen-toolkit/ocsigen-toolkit-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib opam
+
+DESCRIPTION="User interface widgets for Ocsigen applications"
+HOMEPAGE="https://github.com/ocsigen/ocsigen-toolkit"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt debug"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ocsigen/ocsigen-toolkit"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ocsigen/ocsigen-toolkit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]
+ >dev-ml/js_of_ocaml-2.7:=
+ >=dev-ml/eliom-5.1:=[ppx]
+ dev-ml/ppx_deriving:=
+ dev-ml/calendar:=
+ dev-ml/lwt:="
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake \
+ DEBUG="$(usex debug yes no)" \
+ NATIVE="$(usex ocamlopt yes no)" \
+ all
+}
+
+src_install() {
+ findlib_src_preinst
+ OCAMLPATH="${OCAMLFIND_DESTDIR}" emake install
+ opam_src_install
+ dodoc README.md
+}