summaryrefslogtreecommitdiff
path: root/dev-ml/ocsigen-toolkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/ocsigen-toolkit
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/ocsigen-toolkit')
-rw-r--r--dev-ml/ocsigen-toolkit/Manifest5
-rw-r--r--dev-ml/ocsigen-toolkit/metadata.xml11
-rw-r--r--dev-ml/ocsigen-toolkit/ocsigen-toolkit-1.0.0.ebuild46
-rw-r--r--dev-ml/ocsigen-toolkit/ocsigen-toolkit-9999.ebuild46
4 files changed, 108 insertions, 0 deletions
diff --git a/dev-ml/ocsigen-toolkit/Manifest b/dev-ml/ocsigen-toolkit/Manifest
new file mode 100644
index 000000000000..4241e296df26
--- /dev/null
+++ b/dev-ml/ocsigen-toolkit/Manifest
@@ -0,0 +1,5 @@
+DIST ocsigen-toolkit-1.0.0.tar.gz 69175 SHA256 427e5e4d11215862dcb012b769aea9e6c63b8799d9bde5076893eea3b575a472 SHA512 4776dcceef822ac63fd6d57ce05e870f726c1e1d137bab239b8558acb4ef55f97b847825f621414334b01d30c066ea986d2b8180b80a09719b5b76cb3bb69a20 WHIRLPOOL 4718049847f3a2e7e219a21ec9f8082d467808791010dac92426c8ec7e70c03783f8de5d2bfba600c27c89c46efac0c07502eb04a7de685fae09030d0000526a
+EBUILD ocsigen-toolkit-1.0.0.ebuild 1006 SHA256 d319067770bb4965dbd008989978db7a41522b7005ec19f3ab7d98ad0c188566 SHA512 841c534ab057cba641f0b84bf7884a31c147c054944bb668d71b64711466f1dcdd0057f94627e5ca58e9d066524c5f67e9f6e99be587e15df68fa0b751fd07de WHIRLPOOL e438af3152e1a3bb811b29516f088611b30a7d6f39997acfc2b258e32e1802bcc4bc2e09e874254a25758e9b3ba1b70e491c8fbd43a5a0fa1f31695a47d316a4
+EBUILD ocsigen-toolkit-9999.ebuild 1006 SHA256 d319067770bb4965dbd008989978db7a41522b7005ec19f3ab7d98ad0c188566 SHA512 841c534ab057cba641f0b84bf7884a31c147c054944bb668d71b64711466f1dcdd0057f94627e5ca58e9d066524c5f67e9f6e99be587e15df68fa0b751fd07de WHIRLPOOL e438af3152e1a3bb811b29516f088611b30a7d6f39997acfc2b258e32e1802bcc4bc2e09e874254a25758e9b3ba1b70e491c8fbd43a5a0fa1f31695a47d316a4
+MISC ChangeLog 426 SHA256 9de030b43a6a1458e61d0bf734007cc90c93622e8dd3939d9e8f1f2fd654362e SHA512 997d1a1b9166176ec0ae5f64cae96562fe1312e71bebf7b4549561693937b537cfda9077e34a28b5eb6a326fba06d14469353e9645c74999757350f0285c9aa8 WHIRLPOOL e86b2f8903713a7de8ae61d4d74707b4576c7451fb943a0c15fe38c53dda19e23c778cbaa00d529ddfbb3e679d7005c4cff576ac226079dfc4cdba064b64f28c
+MISC metadata.xml 335 SHA256 0c9f32ac5dbba5339f183cbbba8b81c118f8b6c2f93c4857b20b8e6f78f9d0c8 SHA512 606d269d0a0bff054f700a2e9c3ae7904e75e07aec99adf71e59a4980f10f7bb8bb2c39c93ad5d531bf4ee774906b045c899194ee5f7411a1f2e90c633d3b5b1 WHIRLPOOL b43e17f20a47806777b30de7b45fd0411069cb571b79ccfd24f04fb3a1befd8a96c791bd7af056ee3aa30e2062fe4175a4b5de50623ca6ec82a3d75384bdef19
diff --git a/dev-ml/ocsigen-toolkit/metadata.xml b/dev-ml/ocsigen-toolkit/metadata.xml
new file mode 100644
index 000000000000..570d8b7fe62f
--- /dev/null
+++ b/dev-ml/ocsigen-toolkit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+ <upstream>
+ <remote-id type="github">ocsigen/ocsigen-toolkit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocsigen-toolkit/ocsigen-toolkit-1.0.0.ebuild b/dev-ml/ocsigen-toolkit/ocsigen-toolkit-1.0.0.ebuild
new file mode 100644
index 000000000000..9a99adeda85b
--- /dev/null
+++ b/dev-ml/ocsigen-toolkit/ocsigen-toolkit-1.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib opam
+
+DESCRIPTION="User interface widgets for Ocsigen applications"
+HOMEPAGE="https://github.com/ocsigen/ocsigen-toolkit"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt debug"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ocsigen/ocsigen-toolkit"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ocsigen/ocsigen-toolkit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]
+ >dev-ml/js_of_ocaml-2.7:=
+ >=dev-ml/eliom-5.1:=[ppx]
+ dev-ml/ppx_deriving:=
+ dev-ml/calendar:=
+ dev-ml/lwt:="
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake \
+ DEBUG="$(usex debug yes no)" \
+ NATIVE="$(usex ocamlopt yes no)" \
+ all
+}
+
+src_install() {
+ findlib_src_preinst
+ OCAMLPATH="${OCAMLFIND_DESTDIR}" emake install
+ opam_src_install
+ dodoc README.md
+}
diff --git a/dev-ml/ocsigen-toolkit/ocsigen-toolkit-9999.ebuild b/dev-ml/ocsigen-toolkit/ocsigen-toolkit-9999.ebuild
new file mode 100644
index 000000000000..9a99adeda85b
--- /dev/null
+++ b/dev-ml/ocsigen-toolkit/ocsigen-toolkit-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib opam
+
+DESCRIPTION="User interface widgets for Ocsigen applications"
+HOMEPAGE="https://github.com/ocsigen/ocsigen-toolkit"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt debug"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ocsigen/ocsigen-toolkit"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ocsigen/ocsigen-toolkit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]
+ >dev-ml/js_of_ocaml-2.7:=
+ >=dev-ml/eliom-5.1:=[ppx]
+ dev-ml/ppx_deriving:=
+ dev-ml/calendar:=
+ dev-ml/lwt:="
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake \
+ DEBUG="$(usex debug yes no)" \
+ NATIVE="$(usex ocamlopt yes no)" \
+ all
+}
+
+src_install() {
+ findlib_src_preinst
+ OCAMLPATH="${OCAMLFIND_DESTDIR}" emake install
+ opam_src_install
+ dodoc README.md
+}