summaryrefslogtreecommitdiff
path: root/dev-ml/ocamlgraph
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-01 08:00:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-01 08:00:51 +0100
commitd1c14e94a73fba924761cdad7298f3e48c6bc160 (patch)
tree60b97f0d81b3b06b06acc48ff8856d7c4afa2989 /dev-ml/ocamlgraph
parentd5ee59790ee8298b8599b0aa0fa21a98b972a44d (diff)
gentoo auto-resync : 01:07:2024 - 08:00:50
Diffstat (limited to 'dev-ml/ocamlgraph')
-rw-r--r--dev-ml/ocamlgraph/Manifest2
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-2.1.0.ebuild22
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-ml/ocamlgraph/Manifest b/dev-ml/ocamlgraph/Manifest
index dedb9823165f..c617fd6ea64f 100644
--- a/dev-ml/ocamlgraph/Manifest
+++ b/dev-ml/ocamlgraph/Manifest
@@ -1,3 +1,5 @@
DIST ocamlgraph-2.0.0.tbz 298912 BLAKE2B a4bb04c74f4dba8b0f37cdf8ab9a82ef5120b1e7f5b5570e67aac35de16e4553c93759acfa5c218e07dc7c036750d92d2c557c7d58247783718f691c5319ded8 SHA512 c4973ac03bdff52d1c8a1ed01c81e0fbe2f76486995e57ff4e4a11bcc7b1793556139d52a81ff14ee8c8de52f1b40e4bd359e60a2ae626cc630ebe8bccefb3f1
+DIST ocamlgraph-2.1.0.tbz 311740 BLAKE2B 938def0cfce8ad5c2d47058bf533715cf9359d25ea968ceeb2959cb968e08a9acf442e21cd16c1e93df1919177c01105c1139c71be6e53c6e1b22aa511e2619f SHA512 8ee77bc1ef27bef41171b5718a73342dca8adc4b4592ff835038cd21e8c91152a0f9500b4034f664d1db7a09dab1efcc3be5d7c59260d6b33710b82a1fb2f196
EBUILD ocamlgraph-2.0.0-r1.ebuild 562 BLAKE2B c9c5c1786054d30d380cadaa84f3e35f9a8261667dccd6e62ef015c9f8aefaac8aa031a31e82ab7c030d75573e5aceae8d3300d57cf8f607ab5fd468afdc0b18 SHA512 740245b18ed0321782bf810fa37ef21cf9c5099cd3fcf086376eb7bde9523ca044725ce10d4adf683fd665438daf6dce19fd117359f634b761dfc95e6ac7e2f6
+EBUILD ocamlgraph-2.1.0.ebuild 537 BLAKE2B 4d22d66744e775e8fa05b0c71a9745f1232c2cb0fbe75d22e0c8e1c8478063cf7f39f1d78f53c5929677f261d14a40e6ec78e973598d0e40b81c841ca477ed43 SHA512 7556109566196243465d7f84296bb565dcdc271ba75a93aa9256b8fe53ba8fc9a4137cf9661b4f8b3809b5c6559cd7c032732d7bd2cd124aa3b61303f911d8cc
MISC metadata.xml 321 BLAKE2B 540df25b57b60f517c952378845e8bc68b40af40a2b660fc6b505fbf10bd8a1e44da29722b64a11aeb6507ef82aed397d57feb08fa1a6ac4f5f6b997208f2616 SHA512 e24eed2f33773bf59f28cba7e926bf707523acce1c32191e92e13f2b56c426c2434f4c2cd6239aa5d53952b9bc0e152439a6147302b1207c542cadc64d2a4dd5
diff --git a/dev-ml/ocamlgraph/ocamlgraph-2.1.0.ebuild b/dev-ml/ocamlgraph/ocamlgraph-2.1.0.ebuild
new file mode 100644
index 000000000000..9ed28c085ec3
--- /dev/null
+++ b/dev-ml/ocamlgraph/ocamlgraph-2.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="O'Caml Graph library"
+HOMEPAGE="http://ocamlgraph.lri.fr/index.en.html"
+SRC_URI="https://github.com/backtracking/${PN}/releases/download/${PV}/${P}.tbz"
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+RDEPEND="
+ dev-ml/stdlib-shims:=[ocamlopt?]
+ dev-ml/graphics:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+IUSE="+ocamlopt"
+
+src_compile() {
+ dune-compile ocamlgraph
+}