summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-websocket
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/ocaml-websocket
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/ocaml-websocket')
-rw-r--r--dev-ml/ocaml-websocket/Manifest3
-rw-r--r--dev-ml/ocaml-websocket/metadata.xml15
-rw-r--r--dev-ml/ocaml-websocket/ocaml-websocket-2.9.ebuild51
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-ml/ocaml-websocket/Manifest b/dev-ml/ocaml-websocket/Manifest
new file mode 100644
index 000000000000..c720db7c1214
--- /dev/null
+++ b/dev-ml/ocaml-websocket/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-websocket-2.9.tar.gz 23946 SHA256 fcf53aec904f0defbd76ec4aea9a4363bb38912b76c84cf97ffa1a5bfcd260c3 SHA512 eab5e4f971985c03ca70b46abb54ca8a09491e5ebc803b57ddf8447447b6926da2117fd882c7cb5a9a7282290e756f535e4584f09cbd21ce2554f20df1db7ae8 WHIRLPOOL fbefe08995de2721370571a66021c8dd6f51d65f142e310f1cf34f4fdcc8ea4adb6ab3dbec70fa01660cdf1a2c22cffc31a4c87ae674864b528839c06d96a423
+EBUILD ocaml-websocket-2.9.ebuild 1212 SHA256 8dab37bba723b4fe0a176407528b9c9f646290e4510bbcee615dd2c5568e3219 SHA512 8c35ce20d678495f29c541f08de7295f60d3560a1e6be9a677f11758b1912204b68bc31273823c9a8f82efc24cb53562b06a9ae89e68d5ddb11474030e18d847 WHIRLPOOL 738c5a33712f1435684821de99a230566694cce74d6dd86bea7cebce749698edc06bd892f81f0dee57eb7a1ec00eee0a528fb76a24e1b43768a59efa24155643
+MISC metadata.xml 571 SHA256 ba86d1b06b969d5348e99bfb844ce5d6aec64000e6d5c4daccc2af20fbc03b7c SHA512 27c2ddfbebccf44ac986917632752ffa184d77ce4ca1ad73767d2d18f978d072c9ad965645d0e598136643241b70a134223a116ae401c14c1d0f56d4c1c8e57f WHIRLPOOL d86a259117d0f3c0553dfd54016647d5fe5aaad6db42d51812529fa6c434d03e2dea3107d8b1a8d6a9a639d674077ab8cb571686d33e6d62ed6e6fe01922031f
diff --git a/dev-ml/ocaml-websocket/metadata.xml b/dev-ml/ocaml-websocket/metadata.xml
new file mode 100644
index 000000000000..3e6d4b66b87e
--- /dev/null
+++ b/dev-ml/ocaml-websocket/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <use>
+ <flag name="async">Enables support for the <pkg>dev-ml/async</pkg> asynchronous execution library.</flag>
+ <flag name="lwt">Enables support for the <pkg>dev-ml/lwt</pkg> cooperative light-weight thread library.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">vbmithr/ocaml-websocket</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-websocket/ocaml-websocket-2.9.ebuild b/dev-ml/ocaml-websocket/ocaml-websocket-2.9.ebuild
new file mode 100644
index 000000000000..359784d9c447
--- /dev/null
+++ b/dev-ml/ocaml-websocket/ocaml-websocket-2.9.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit opam
+
+DESCRIPTION="Websocket library for OCaml"
+HOMEPAGE="https://github.com/vbmithr/ocaml-websocket"
+SRC_URI="https://github.com/vbmithr/ocaml-websocket/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt async +ssl lwt"
+
+DEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ dev-ml/astring:=[ocamlopt(+)?]
+ dev-ml/ocaml-cohttp:=[ocamlopt(+)?,async?,lwt?]
+ dev-ml/cppo:=[ocamlopt(+)?]
+ dev-ml/ocplib-endian:=[ocamlopt(+)?]
+ async? (
+ dev-ml/async:=[ocamlopt(+)?]
+ ssl? ( dev-ml/async_ssl:=[ocamlopt(+)?] )
+ )
+ lwt? ( dev-ml/lwt:=[ocamlopt(+)?] )
+ ssl? ( dev-ml/cryptokit:=[ocamlopt(+)?] )
+
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/ocamlbuild"
+
+src_compile() {
+ ocaml pkg/build.ml \
+ native=$(usex ocamlopt true false) \
+ native-dynlink=$(usex ocamlopt true false) \
+ lwt=$(usex lwt true false) \
+ async=$(usex async true false) \
+ async_ssl=$(usex async "$(usex ssl true false)" false) \
+ nocrypto=false \
+ cryptokit=$(usex ssl true false) \
+ test=false \
+ || die
+}
+
+src_install() {
+ opam_src_install websocket
+ dodoc README CHANGES
+}