summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-websocket
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-ml/ocaml-websocket
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocaml-websocket')
-rw-r--r--dev-ml/ocaml-websocket/Manifest3
-rw-r--r--dev-ml/ocaml-websocket/metadata.xml15
-rw-r--r--dev-ml/ocaml-websocket/ocaml-websocket-2.9.ebuild51
3 files changed, 0 insertions, 69 deletions
diff --git a/dev-ml/ocaml-websocket/Manifest b/dev-ml/ocaml-websocket/Manifest
deleted file mode 100644
index 845adc2fdd5a..000000000000
--- a/dev-ml/ocaml-websocket/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST ocaml-websocket-2.9.tar.gz 23946 BLAKE2B adea61c5b163c995f3fcdc9789ef718bbfc5b22f3ef755795d54d0ba7357797fd5c358da88a7fbc5986c728b2705d5f34c7f3d4c8f2c2a9aa857a4b6add98b5f SHA512 eab5e4f971985c03ca70b46abb54ca8a09491e5ebc803b57ddf8447447b6926da2117fd882c7cb5a9a7282290e756f535e4584f09cbd21ce2554f20df1db7ae8
-EBUILD ocaml-websocket-2.9.ebuild 1212 BLAKE2B 51e836414bd01bdc5f2bb3494096527aa70c54e83138469dcaa90ebc16d66a85ca096711170fd2da5ea107f434779619d8e7cffc4c3884ff1c29c7ab9bbce359 SHA512 8c35ce20d678495f29c541f08de7295f60d3560a1e6be9a677f11758b1912204b68bc31273823c9a8f82efc24cb53562b06a9ae89e68d5ddb11474030e18d847
-MISC metadata.xml 571 BLAKE2B 7372439e952133ef21ad360bbcb759a0f2f8a5b708b47f816ac7f8074a4cd87f2a1939f4bb1246f7e61a4d092cc7cc1ea09099253cefdfd2ad762be71c46d1c5 SHA512 27c2ddfbebccf44ac986917632752ffa184d77ce4ca1ad73767d2d18f978d072c9ad965645d0e598136643241b70a134223a116ae401c14c1d0f56d4c1c8e57f
diff --git a/dev-ml/ocaml-websocket/metadata.xml b/dev-ml/ocaml-websocket/metadata.xml
deleted file mode 100644
index 3e6d4b66b87e..000000000000
--- a/dev-ml/ocaml-websocket/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ml@gentoo.org</email>
- <name>Gentoo ML Project</name>
- </maintainer>
- <use>
- <flag name="async">Enables support for the <pkg>dev-ml/async</pkg> asynchronous execution library.</flag>
- <flag name="lwt">Enables support for the <pkg>dev-ml/lwt</pkg> cooperative light-weight thread library.</flag>
- </use>
- <upstream>
- <remote-id type="github">vbmithr/ocaml-websocket</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-ml/ocaml-websocket/ocaml-websocket-2.9.ebuild b/dev-ml/ocaml-websocket/ocaml-websocket-2.9.ebuild
deleted file mode 100644
index 359784d9c447..000000000000
--- a/dev-ml/ocaml-websocket/ocaml-websocket-2.9.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit opam
-
-DESCRIPTION="Websocket library for OCaml"
-HOMEPAGE="https://github.com/vbmithr/ocaml-websocket"
-SRC_URI="https://github.com/vbmithr/ocaml-websocket/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="+ocamlopt async +ssl lwt"
-
-DEPEND="
- dev-lang/ocaml:=[ocamlopt?]
- dev-ml/astring:=[ocamlopt(+)?]
- dev-ml/ocaml-cohttp:=[ocamlopt(+)?,async?,lwt?]
- dev-ml/cppo:=[ocamlopt(+)?]
- dev-ml/ocplib-endian:=[ocamlopt(+)?]
- async? (
- dev-ml/async:=[ocamlopt(+)?]
- ssl? ( dev-ml/async_ssl:=[ocamlopt(+)?] )
- )
- lwt? ( dev-ml/lwt:=[ocamlopt(+)?] )
- ssl? ( dev-ml/cryptokit:=[ocamlopt(+)?] )
-
-"
-RDEPEND="${DEPEND}"
-DEPEND="${DEPEND}
- dev-ml/ocamlbuild"
-
-src_compile() {
- ocaml pkg/build.ml \
- native=$(usex ocamlopt true false) \
- native-dynlink=$(usex ocamlopt true false) \
- lwt=$(usex lwt true false) \
- async=$(usex async true false) \
- async_ssl=$(usex async "$(usex ssl true false)" false) \
- nocrypto=false \
- cryptokit=$(usex ssl true false) \
- test=false \
- || die
-}
-
-src_install() {
- opam_src_install websocket
- dodoc README CHANGES
-}