summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-stdint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-ml/ocaml-stdint
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-ml/ocaml-stdint')
-rw-r--r--dev-ml/ocaml-stdint/Manifest3
-rw-r--r--dev-ml/ocaml-stdint/metadata.xml24
-rw-r--r--dev-ml/ocaml-stdint/ocaml-stdint-0.7.0.ebuild18
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ml/ocaml-stdint/Manifest b/dev-ml/ocaml-stdint/Manifest
new file mode 100644
index 000000000000..8b64f6d4d776
--- /dev/null
+++ b/dev-ml/ocaml-stdint/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-stdint-0.7.0.tar.gz 34507 BLAKE2B d06768911798a6a3736b68395fc5ca2d53288fe0056953ed189938b10aeeb9469511fc1ece39e49c403954f4bd88034d63ec53d7e8b63d8e8c41ff0761ccb2e6 SHA512 5e0c4164cb1f55a63f0928f5c1868cc2bba61d356b63cc20cb6b066fd09824eb99d6d1fd577f52678155d6744a591fdd8377b4c44bbe015918462f4576b43529
+EBUILD ocaml-stdint-0.7.0.ebuild 461 BLAKE2B 8d20e15537afdc453dbbeedc8084a2fec5cd1392f24afa1bee35c8fbe83f73f1abfb428b6d89be667232e4a24227bca959c9e3916c37c3a4896f4ef7fb740ef8 SHA512 eefd3a5e34b11c552042fe0f3e725fcfabc9c2b61661b5ee50792edccc61b72ad075550b1d2ecf2c9ceb8b5bfba425177d91bc1e61da2b745ee411d83a411163
+MISC metadata.xml 1070 BLAKE2B ac1387773e133410d8a579534ea42dbad6d9b349d31f9108c11d0969bce0c31a5bdc6fa7aca0323203106ca96ccfe8e118fd83385e335bb758b0aef8f34b769b SHA512 56e8bec1232bd152b041dfaee90c70424c5c9aacfdca4ec7cfa0d54527dbf620f2d5b525cbf64c5f8c7cc89fdf91e03044217ffdb003da484e983e70bb0b9cfe
diff --git a/dev-ml/ocaml-stdint/metadata.xml b/dev-ml/ocaml-stdint/metadata.xml
new file mode 100644
index 000000000000..a4c37e9a3e5a
--- /dev/null
+++ b/dev-ml/ocaml-stdint/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription>
+ The stdint library provides signed and unsigned integer types of various
+ fixed widths: 8, 16, 24, 32, 40, 48, 56, 64 and 128 bit.
+ This interface is similar to Int32 and Int64 from the base library but
+ provides more functions and constants like arithmetic and bit-wise
+ operations, constants like maximum and minimum values, infix operators
+ conversion to and from every other integer type (including int, float and
+ nativeint), parsing from and conversion to readable strings (binary, octal,
+ decimal, hexademical), conversion to and from buffers in both big endian
+ and little endian byte order.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/andrenth/ocaml-stdint/issues/</bugs-to>
+ <remote-id type="github">andrenth/ocaml-stdint</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-stdint/ocaml-stdint-0.7.0.ebuild b/dev-ml/ocaml-stdint/ocaml-stdint-0.7.0.ebuild
new file mode 100644
index 000000000000..1dcb81d9a5d7
--- /dev/null
+++ b/dev-ml/ocaml-stdint/ocaml-stdint-0.7.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="stdint"
+
+inherit dune
+
+DESCRIPTION="Signed and unsigned integer types having specified widths"
+HOMEPAGE="https://github.com/andrenth/ocaml-stdint"
+SRC_URI="https://github.com/andrenth/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test" # some tests fails