summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-stdint/ocaml-stdint-0.7.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-02 00:07:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-02 00:07:23 +0100
commit6657c680376cedf378fcf328e5fa03ed3b41d580 (patch)
tree44ea8d174f647daca562b9bdcbcb527a85a77d0a /dev-ml/ocaml-stdint/ocaml-stdint-0.7.2-r1.ebuild
parent1551fe56fd6ba43a94509cffc61b6bf854b7ac9f (diff)
gentoo auto-resync : 02:06:2024 - 00:07:23
Diffstat (limited to 'dev-ml/ocaml-stdint/ocaml-stdint-0.7.2-r1.ebuild')
-rw-r--r--dev-ml/ocaml-stdint/ocaml-stdint-0.7.2-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-ml/ocaml-stdint/ocaml-stdint-0.7.2-r1.ebuild b/dev-ml/ocaml-stdint/ocaml-stdint-0.7.2-r1.ebuild
new file mode 100644
index 000000000000..ef16ff625fd4
--- /dev/null
+++ b/dev-ml/ocaml-stdint/ocaml-stdint-0.7.2-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="stdint"
+
+inherit dune
+
+DESCRIPTION="Signed and unsigned integer types having specified widths"
+HOMEPAGE="https://github.com/andrenth/ocaml-stdint"
+SRC_URI="https://github.com/andrenth/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test" # some tests fails
+BDEPEND=">=dev-ml/dune-3"