summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-ssl/ocaml-ssl-0.5.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-06 22:33:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-06 22:33:57 +0100
commitc4b3d05f2d4415c0d6f135a3ea0d2055d6e055b5 (patch)
tree3ed89f0ec34cf85a0c06c027a6889e7890e08db6 /dev-ml/ocaml-ssl/ocaml-ssl-0.5.12.ebuild
parent8965d348ad07c326c8e17e3137c151bcc98b0a53 (diff)
gentoo auto-resync : 06:09:2022 - 22:33:57
Diffstat (limited to 'dev-ml/ocaml-ssl/ocaml-ssl-0.5.12.ebuild')
-rw-r--r--dev-ml/ocaml-ssl/ocaml-ssl-0.5.12.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ssl/ocaml-ssl-0.5.12.ebuild b/dev-ml/ocaml-ssl/ocaml-ssl-0.5.12.ebuild
new file mode 100644
index 000000000000..4c76a96825c3
--- /dev/null
+++ b/dev-ml/ocaml-ssl/ocaml-ssl-0.5.12.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DUNE_PKG_NAME=ssl
+
+inherit dune
+
+DESCRIPTION="OCaml bindings for OpenSSL"
+HOMEPAGE="https://github.com/savonet/ocaml-ssl"
+SRC_URI="https://github.com/savonet/ocaml-ssl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="+ocamlopt"
+
+BDEPEND="dev-ml/dune-configurator"
+DEPEND="dev-libs/openssl:0=
+ >=dev-lang/ocaml-3.10:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dune_src_install
+
+ dodoc CHANGES.md README.md
+}