summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-pcap/ocaml-pcap-0.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocaml-pcap/ocaml-pcap-0.4.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocaml-pcap/ocaml-pcap-0.4.0.ebuild')
-rw-r--r--dev-ml/ocaml-pcap/ocaml-pcap-0.4.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/ocaml-pcap/ocaml-pcap-0.4.0.ebuild b/dev-ml/ocaml-pcap/ocaml-pcap-0.4.0.ebuild
new file mode 100644
index 000000000000..01eb83b0bfc0
--- /dev/null
+++ b/dev-ml/ocaml-pcap/ocaml-pcap-0.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Read and write pcap-formatted network packet traces."
+HOMEPAGE="https://github.com/mirage/ocaml-pcap https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Blockers taken from opam file and only relevant
+# if MirageOS should enter portage.
+RDEPEND="
+ dev-ml/ocaml-ipaddr:=
+ !dev-ml/mirage-net-socket
+ !<dev-ml/mirage-0.9.2
+ >=dev-ml/ocaml-cstruct-0.6.0:=[ppx(-)]
+"
+DEPEND="
+ test? ( dev-ml/ounit
+ >=dev-ml/lwt-2.4.0 )
+ ${RDEPEND}
+"
+
+DOCS=( CHANGES MAINTAINERS README.md )