summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-pcap/ocaml-pcap-0.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/ocaml-pcap/ocaml-pcap-0.4.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/ocaml-pcap/ocaml-pcap-0.4.0.ebuild')
-rw-r--r--dev-ml/ocaml-pcap/ocaml-pcap-0.4.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/ocaml-pcap/ocaml-pcap-0.4.0.ebuild b/dev-ml/ocaml-pcap/ocaml-pcap-0.4.0.ebuild
new file mode 100644
index 000000000000..01eb83b0bfc0
--- /dev/null
+++ b/dev-ml/ocaml-pcap/ocaml-pcap-0.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Read and write pcap-formatted network packet traces."
+HOMEPAGE="https://github.com/mirage/ocaml-pcap https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Blockers taken from opam file and only relevant
+# if MirageOS should enter portage.
+RDEPEND="
+ dev-ml/ocaml-ipaddr:=
+ !dev-ml/mirage-net-socket
+ !<dev-ml/mirage-0.9.2
+ >=dev-ml/ocaml-cstruct-0.6.0:=[ppx(-)]
+"
+DEPEND="
+ test? ( dev-ml/ounit
+ >=dev-ml/lwt-2.4.0 )
+ ${RDEPEND}
+"
+
+DOCS=( CHANGES MAINTAINERS README.md )