summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-mysql
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
commit79599515788b85b18aa655e7b7f8cc05c1bbddd8 (patch)
treeade7cb031f363fad64c77139dea7aa3d81908537 /dev-ml/ocaml-mysql
parent6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (diff)
gentoo resync : 16.02.1018
Diffstat (limited to 'dev-ml/ocaml-mysql')
-rw-r--r--dev-ml/ocaml-mysql/Manifest3
-rw-r--r--dev-ml/ocaml-mysql/ocaml-mysql-1.2.1-r1.ebuild38
-rw-r--r--dev-ml/ocaml-mysql/ocaml-mysql-1.2.2-r1.ebuild (renamed from dev-ml/ocaml-mysql/ocaml-mysql-1.2.2.ebuild)10
3 files changed, 45 insertions, 6 deletions
diff --git a/dev-ml/ocaml-mysql/Manifest b/dev-ml/ocaml-mysql/Manifest
index 2a699eff82a2..1989ea4a5d58 100644
--- a/dev-ml/ocaml-mysql/Manifest
+++ b/dev-ml/ocaml-mysql/Manifest
@@ -1,5 +1,6 @@
DIST ocaml-mysql-1.2.1.tar.gz 99250 BLAKE2B 576eb7cc7ccf9e747f207faa100adb7f10a17be2083dbd4f1fb352f8a023425eb7917d7bd4756ddafd663657375324207596e97d959f69c704fb1f5126b7d63d SHA512 bf9b4a1bfcc1a8d356a2d74ea9d8de8dd201973b9dc89c06349e814c2368871f5f6ccc2eca25b33fa5fabf4b6d19a5b4b436a1e055b90468f16f575257121e64
DIST ocaml-mysql-1.2.2.tar.gz 99136 BLAKE2B dcc18b51514d7a9bd7bfdf97c3f410aa959cf1b2285bd6d347cd1ebdd51952f687222b16c250d8553f7b2235bff7201978bc8debe22996566412925373c3d9d7 SHA512 2af13de017b73a31c23e0536fd10679eaf5c0692741d19729b08ab58f4d2585f8f7faf0cfac1e3ccc3d3ceffcbd1740f62621ba678c50f545fc3a3a36a17742f
+EBUILD ocaml-mysql-1.2.1-r1.ebuild 663 BLAKE2B 55d8cee043dee7e5f290abfec1ee1f75f524949f55409190da240e224a1262ba1b4c112d54749c89826e9d880a3239d2edf27032e332cc5ff27f90eec85cd463 SHA512 9c58f3ff92bf81428ee3351675c913e0fc4f4369c622558502664ad16f05fe73d9ae77210ae5ca638558c3bafae67a9254a3be665bd1cfc8f9243e71a456e3cf
EBUILD ocaml-mysql-1.2.1.ebuild 670 BLAKE2B 29f9378548b7e97f2f3195458dc2d6513c55b98e5d5f4c000ef4cabcb6d332a3673abed39cd550a9bfe0b5f449fad891b64413ebcc694ed8e9ad59830f976d00 SHA512 fdb0a2a4e5aba6379382541a7bcbbec6266945720b64f2b698eb62e566ba8461de2cc4d8a247629dd7256e7f97a6f1ce2846c8607923aaebed3fecbb1d41692e
-EBUILD ocaml-mysql-1.2.2.ebuild 676 BLAKE2B e45d2790293307cdce31965748534d0b820dd4e4a48828137ac92eb762082afbe54aaa2ddc7689f34433bad60501f4bdb2b1ca892407bdda0f327a149179d9b7 SHA512 51bd1d5048c591f4040ca00355b4af0c0c4382ff03254f03da0b47fe25bfd8ea189838038af65b124c7e552bbe6ed741f2cb117b8ca0348c58e15d2d33f71e10
+EBUILD ocaml-mysql-1.2.2-r1.ebuild 667 BLAKE2B 4ab7269e8cc87c13f1a3b5e40f4306c69e0ad4d883d383dc563786fbe7f3da699aa2c1e54704ce31dcf70e5ca4833835b27f9b767233b6f8ab2e26256dee50da SHA512 d6065ddf86f669fe20a856ff22d2fc5eea9b70a61d53f4181ca3e4332fafb992524f16c1dc44ca17e1b2ddf2b984d476e0a1489338db8361b5ca1d43e947ff5a
MISC metadata.xml 253 BLAKE2B c787c1044c3f674eb5d2d7a0e830965ad53c7a2c8cdfcd95bece6b0557e35237f62afe28464ebe4c88468cd1fd543627349fd41a0aa760fceed1a7d52386eda2 SHA512 9285e04d22e8e41631e6de00e0ba02842cf0e772cd17a1d7ba3864e50eeea50abb06077ea4f9ac920eab3d520bfe28d389b3d04d5c3529af23a68ca68b6857d4
diff --git a/dev-ml/ocaml-mysql/ocaml-mysql-1.2.1-r1.ebuild b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..74bddd8f624a
--- /dev/null
+++ b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to mysql databases"
+SRC_URI="http://ygrek.org.ua/p/release/ocaml-mysql/${P}.tar.gz"
+HOMEPAGE="http://ocaml-mysql.forge.ocamlcore.org/"
+
+DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ sys-libs/zlib
+ dev-db/mysql-connector-c:0="
+
+RDEPEND="$DEPEND"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile()
+{
+ emake all
+ if use ocamlopt; then
+ emake opt
+ fi
+}
+
+src_install()
+{
+ findlib_src_preinst
+ emake install
+
+ dodoc CHANGES README VERSION
+}
diff --git a/dev-ml/ocaml-mysql/ocaml-mysql-1.2.2.ebuild b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.2-r1.ebuild
index a1afca457cf1..87b9fd21e32f 100644
--- a/dev-ml/ocaml-mysql/ocaml-mysql-1.2.2.ebuild
+++ b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit findlib eutils
+inherit findlib
IUSE="+ocamlopt"
@@ -13,7 +13,7 @@ HOMEPAGE="http://ocaml-mysql.forge.ocamlcore.org/"
DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
sys-libs/zlib
- >=virtual/mysql-4.0"
+ dev-db/mysql-connector-c:0="
RDEPEND="$DEPEND"
@@ -34,5 +34,5 @@ src_install()
findlib_src_preinst
emake install
- dodoc CHANGES README VERSION || die
+ dodoc CHANGES README VERSION
}