summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-make
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocaml-make
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocaml-make')
-rw-r--r--dev-ml/ocaml-make/Manifest5
-rw-r--r--dev-ml/ocaml-make/metadata.xml11
-rw-r--r--dev-ml/ocaml-make/ocaml-make-6.37.0.ebuild31
-rw-r--r--dev-ml/ocaml-make/ocaml-make-6.39.0.ebuild31
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-ml/ocaml-make/Manifest b/dev-ml/ocaml-make/Manifest
new file mode 100644
index 000000000000..c03c1cf109e8
--- /dev/null
+++ b/dev-ml/ocaml-make/Manifest
@@ -0,0 +1,5 @@
+DIST ocaml-makefile-6.37.0.tar.gz 49202 BLAKE2B e636b3baf2e088507deb3b6c98f682cd21857988963801ede02a0b8acac4c9bec3f9ae48d76122ab96a6d16d3ede5bcda2a62e351f7f34c230497ee99a1081d8 SHA512 19d318f8b03116c3e999b61c1a2708f483873ab7ae9260225df79888a86eb39e77867fdefe0df23a50ac1fd422b3b774f96b5b58d9dec449710527df1075a36d
+DIST ocaml-makefile-6.39.0.tbz 42477 BLAKE2B 35cffde17f8554f09da24aa1dbc0036b75fcf97516d87d727359899e48c2ccd512d4ae8fcac5319ff30c26e2c9ef813419926a8be103b9de4a9ad6418d1f253e SHA512 54a52c243ce23eba286502aa28ccdbb412aba7cf3ed90e3079ab1b187e61edc8a3197536d5c054b03a871eadbdd0e3b93c47904cb0594ccc2c4ce66ed31daa21
+EBUILD ocaml-make-6.37.0.ebuild 799 BLAKE2B 423db2be2d77ff6851ebcf8ec7b93527e154f1c172a94bbacf6acc8ec2a094c35286bd642dc320ab2e793a4d64b51e74bc70fc1532c6231cab0fac63e67e2b63 SHA512 e3f814e965557044ee1d4ec766a3f5a18b03883ef003014904325a8b40e8d8615849d71331820101f8a0b288dc500fa4adf5bdece7c2e4a07a36c866730feb35
+EBUILD ocaml-make-6.39.0.ebuild 848 BLAKE2B fb26e664cd58b8cfbaecab2cb0146a5315e9f823fd175a6237f9a502b587abbac076916d925597e07f59020fe8dec00945194810dc4e40e1a05916fc49be214f SHA512 d18f31321f9f1f7c57535f362cd350b74ef052441bb518b72cea8dd6ac66526194cbe35db7d41afe217442ff1dcbe8d4b0e18a4cd121e569e0064250502e1f6b
+MISC metadata.xml 343 BLAKE2B 24b622f0de17f80211cf6a0ea88ff59738681022921fb3f7865fc118ee00dd955691450016ee74502a4d164f61b7424ced1aff06b3bd6f40a3e61e7cbb2cb6e6 SHA512 e83447839fb8050aab2981a2a42b953cf3850957d18f8779638c632536d613ed0170de5d01ec11098dc5566975ea6ac2c8dfe653a645e137f7557c2baf47e50f
diff --git a/dev-ml/ocaml-make/metadata.xml b/dev-ml/ocaml-make/metadata.xml
new file mode 100644
index 000000000000..c6bc6c199a22
--- /dev/null
+++ b/dev-ml/ocaml-make/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mmottl/ocaml-makefile</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-make/ocaml-make-6.37.0.ebuild b/dev-ml/ocaml-make/ocaml-make-6.37.0.ebuild
new file mode 100644
index 000000000000..35b705224bc0
--- /dev/null
+++ b/dev-ml/ocaml-make/ocaml-make-6.37.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+DESCRIPTION="Generic O'Caml Makefile for GNU Make"
+HOMEPAGE="https://bitbucket.org/mmottl/ocaml-makefile"
+LICENSE="LGPL-2.1"
+
+DEPEND=""
+RDEPEND=">=dev-lang/ocaml-3.06-r1
+ >=dev-ml/findlib-0.8"
+SRC_URI="https://bitbucket.org/mmottl/ocaml-makefile/downloads/${PN}file-${PV}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="examples"
+S="${WORKDIR}/${PN}file-${PV}"
+
+src_install () {
+ # Just put the OCamlMakefile into /usr/include
+ # where GNU Make will automatically pick it up.
+ insinto /usr/include
+ doins OCamlMakefile
+ # install documentation
+ dodoc README.md CHANGES.txt
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r calc camlp4 gtk idl threads
+ fi
+}
diff --git a/dev-ml/ocaml-make/ocaml-make-6.39.0.ebuild b/dev-ml/ocaml-make/ocaml-make-6.39.0.ebuild
new file mode 100644
index 000000000000..e220e306ac95
--- /dev/null
+++ b/dev-ml/ocaml-make/ocaml-make-6.39.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+DESCRIPTION="Generic O'Caml Makefile for GNU Make"
+HOMEPAGE="http://mmottl.github.io/ocaml-makefile/ https://github.com/mmottl/ocaml-makefile"
+LICENSE="LGPL-2.1"
+
+DEPEND=""
+RDEPEND=">=dev-lang/ocaml-3.06-r1
+ >=dev-ml/findlib-0.8"
+SRC_URI="https://github.com/mmottl/ocaml-makefile/releases/download/${PV}/ocaml-makefile-${PV}.tbz"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="examples"
+S="${WORKDIR}/${PN}file-${PV}"
+
+src_install () {
+ # Just put the OCamlMakefile into /usr/include
+ # where GNU Make will automatically pick it up.
+ insinto /usr/include
+ doins OCamlMakefile
+ # install documentation
+ dodoc README.md CHANGES.md
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r calc camlp4 gtk idl threads
+ fi
+}