summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-inifiles
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-ml/ocaml-inifiles
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-ml/ocaml-inifiles')
-rw-r--r--dev-ml/ocaml-inifiles/Manifest4
-rw-r--r--dev-ml/ocaml-inifiles/files/ocaml-inifiles-1.2-inifiles.ml.patch11
-rw-r--r--dev-ml/ocaml-inifiles/metadata.xml9
-rw-r--r--dev-ml/ocaml-inifiles/ocaml-inifiles-1.2.ebuild30
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-ml/ocaml-inifiles/Manifest b/dev-ml/ocaml-inifiles/Manifest
new file mode 100644
index 000000000000..110af9989ae1
--- /dev/null
+++ b/dev-ml/ocaml-inifiles/Manifest
@@ -0,0 +1,4 @@
+AUX ocaml-inifiles-1.2-inifiles.ml.patch 210 BLAKE2B add08bffd9afb4a4d6046b24ca18115c4ed295069088018cb77aebb20597973852459697def9d7e8261933471486fc2c89f26ea39f9e6d47083ed5dd12b25556 SHA512 c9e5b2226ee497fe2e9633532f9d7df05da52c73bddf3351913f0f037422170068296e5a6b6e40fced3c03eef3702affe9386d928c955ed268c570d16610a91c
+DIST ocaml-inifiles_1.2.orig.tar.gz 11642 BLAKE2B 9970a5df9290c0532ad54eb8df6737f2e22385d5de6defd9681f115e2c0c62217e56dbf3bde91424e3a75f56d6e00daa698e2029ae457cb55a3495a8b2144490 SHA512 d57016e338caade7ceff416b698ad320da7e5ef376430d5bca9115ca0abc219a8072c9fddc8c8388c0b7ed404801e5158827d86577be49658611bd830e8814ef
+EBUILD ocaml-inifiles-1.2.ebuild 644 BLAKE2B d5c0f87c3951b3781d5a465f69d906fcb92f28b76740f90de94722442959544eb1ce01ce10e78abd7d409581a5f7be0db605f3017dcfe7e8d526d384c315f965 SHA512 847bfa37c55a11cc3367c761ffc592b4b67df07c24ba6f02e1580c38b113e2016c52705cc4cdb25d6a9e0f9c754db16ffc48e8d943e9a471ac8635f04c93f575
+MISC metadata.xml 239 BLAKE2B 0d4d408425414c16590fb3398ae893ab574451eb5831872be0fcc33f2de6ea7c839eb1857a3fa05062eaf7e7384ee7527f035cfeaacbfc896f1d7319663708e6 SHA512 d74bde3f33ed3b510b6507a43e64cd9f1d682a4e3849e9d8e1bf0a0eccfe47e1257f28260e2456ae64e9050ac44eb2f846bcbe6b83f927f1a71f8c054c0a937f
diff --git a/dev-ml/ocaml-inifiles/files/ocaml-inifiles-1.2-inifiles.ml.patch b/dev-ml/ocaml-inifiles/files/ocaml-inifiles-1.2-inifiles.ml.patch
new file mode 100644
index 000000000000..17c060c8a208
--- /dev/null
+++ b/dev-ml/ocaml-inifiles/files/ocaml-inifiles-1.2-inifiles.ml.patch
@@ -0,0 +1,11 @@
+--- a/inifiles.ml
++++ b/inifiles.ml
+@@ -257,7 +257,7 @@
+ func
+ initial
+ (List.rev_map
+- (new inifile)
++ (fun x -> new inifile x)
+ (List.filter
+ check_file
+ (List.rev_map
diff --git a/dev-ml/ocaml-inifiles/metadata.xml b/dev-ml/ocaml-inifiles/metadata.xml
new file mode 100644
index 000000000000..39ab33fa4ce0
--- /dev/null
+++ b/dev-ml/ocaml-inifiles/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-inifiles/ocaml-inifiles-1.2.ebuild b/dev-ml/ocaml-inifiles/ocaml-inifiles-1.2.ebuild
new file mode 100644
index 000000000000..bf249ff1364b
--- /dev/null
+++ b/dev-ml/ocaml-inifiles/ocaml-inifiles-1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="A small OCaml library to read and write .ini files"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="http://archive.ubuntu.com/ubuntu/pool/universe/o/${PN}/${PN}_${PV}.orig.tar.gz"
+S="${WORKDIR}/inifiles-${PV}"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="dev-ml/pcre-ocaml:="
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-inifiles.ml.patch )
+
+src_compile() {
+ emake -j1
+ use ocamlopt && emake -j1 opt
+}
+
+src_install() {
+ findlib_src_install
+}