summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-gettext-camomile/ocaml-gettext-camomile-0.4.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-18 23:56:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-18 23:56:27 +0100
commit93d0bbd7df69c2081c2b2347ea6c88b8e967d537 (patch)
tree5a3d99a67d4243c300c70a88d52d651c1de4688d /dev-ml/ocaml-gettext-camomile/ocaml-gettext-camomile-0.4.2-r1.ebuild
parentb481b54b8432c46df354eedc3532b0420a38fd5a (diff)
gentoo auto-resync : 18:04:2023 - 23:56:26
Diffstat (limited to 'dev-ml/ocaml-gettext-camomile/ocaml-gettext-camomile-0.4.2-r1.ebuild')
-rw-r--r--dev-ml/ocaml-gettext-camomile/ocaml-gettext-camomile-0.4.2-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/ocaml-gettext-camomile/ocaml-gettext-camomile-0.4.2-r1.ebuild b/dev-ml/ocaml-gettext-camomile/ocaml-gettext-camomile-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..a9d71a8d2edf
--- /dev/null
+++ b/dev-ml/ocaml-gettext-camomile/ocaml-gettext-camomile-0.4.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=${PN/-camomile/}
+MY_P=${P/-camomile/}
+DUNE_PKG_NAME="gettext-camomile"
+inherit dune
+
+DESCRIPTION="Support for internationalization of OCaml programs using the Camomile library"
+HOMEPAGE="https://github.com/gildor478/ocaml-gettext"
+SRC_URI="https://github.com/gildor478/ocaml-gettext/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="amd64"
+IUSE="+ocamlopt test"
+RESTRICT="test" # Tests fail
+
+BDEPEND="
+ >=dev-ml/cppo-1.6.6
+ dev-ml/dune-configurator
+"
+RDEPEND="
+ dev-ml/base:=
+ <dev-ml/camomile-2.0.0:=[ocamlopt]
+ dev-ml/ocaml-gettext:=
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-ml/ounit2[ocamlopt=]
+ dev-ml/ocaml-fileutils
+ )
+"
+
+src_prepare() {
+ default
+
+ # Port to dev-ml/ounit2
+ sed -i -e 's/oUnit/ounit2/' test/{,common,test-camomile,test-stub}/dune || die
+}