summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-fileutils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-ml/ocaml-fileutils
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-ml/ocaml-fileutils')
-rw-r--r--dev-ml/ocaml-fileutils/Manifest2
-rw-r--r--dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.3.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/ocaml-fileutils/Manifest b/dev-ml/ocaml-fileutils/Manifest
index bb19942263b7..eedbdacfd2c9 100644
--- a/dev-ml/ocaml-fileutils/Manifest
+++ b/dev-ml/ocaml-fileutils/Manifest
@@ -1,3 +1,5 @@
DIST ocaml-fileutils-0.6.2.tar.bz2 43060 BLAKE2B 20828875a25b1a9d2a41bf495cda00b0ac753efa20111b32a9d2ca439a56e9f07bf0953d16ee9148cf065e204fa1d8d624eaa89f6f4ae7e1613fdaa7cb44fc24 SHA512 104c7389832f22ec189ce6f1596144b28dcaeea7d23d5b19d369c44e54326e97fcb7b4f4c4a8d2965523e63b35b594a1351b7e630dde590871efe512fe38853c
+DIST ocaml-fileutils-0.6.3.tar.bz2 43157 BLAKE2B a9adf17d028abd664dbdec3fefa301a6b502941a6da4ef9c3ef02b876f187d224e404f6a9ffb5460035ba475154c60109a5218cb8b9bb36153ca791f8d218e7d SHA512 2c5e75b894e9f5e3b003d61977a87f5c6964a89d844949eedc55f97c5875cc52052182420bbb4e73925d306479c66400df74e4adfccc5b2102347d13e99505cf
EBUILD ocaml-fileutils-0.6.2.ebuild 751 BLAKE2B 90a512b800b5038777e141bb95452a413e24500e8e325abecaf347cd7ac39975b090d285371b27f0b1a888c4fa522a7ae437f98db053331a0a20781b16f71bfc SHA512 6358e0ab33ba4a5973b346a1cefe6f719fdbdd603674b33dbcec1c13652515b08b374754231ce6f3aa3ed31dc9711376771d6704fa4363a0b3d439dc2fea88a1
+EBUILD ocaml-fileutils-0.6.3.ebuild 751 BLAKE2B 90a512b800b5038777e141bb95452a413e24500e8e325abecaf347cd7ac39975b090d285371b27f0b1a888c4fa522a7ae437f98db053331a0a20781b16f71bfc SHA512 6358e0ab33ba4a5973b346a1cefe6f719fdbdd603674b33dbcec1c13652515b08b374754231ce6f3aa3ed31dc9711376771d6704fa4363a0b3d439dc2fea88a1
MISC metadata.xml 829 BLAKE2B d5b5d0678a3bfe6d9aa4f99e2d79478d528d726d53f899cd2400a6ca45b20281bcaa606d1c9028cf84bdca1cb6c9bd0f5d28f5c8fe4db1bf1ed9ac9b044d6649 SHA512 84c9e1c83e6670ae473dc9d3e7227d82ae3d4bd57c9ed0b5ef80eacd8e1e8f074cae7babcd9ff331a4c5f1bfd14f561a094857db31cb7a85c6ec3329bff6e0d6
diff --git a/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.3.ebuild b/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.3.ebuild
new file mode 100644
index 000000000000..72c2b68e4139
--- /dev/null
+++ b/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="fileutils"
+
+inherit dune
+
+DESCRIPTION="Pure OCaml functions to manipulate real file (POSIX like) and filename"
+HOMEPAGE="https://github.com/gildor478/ocaml-fileutils"
+SRC_URI="https://github.com/gildor478/${PN}/releases/download/v${PV}/${DUNE_PKG_NAME}-v${PV}.tbz -> ${P}.tar.bz2"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-ml/ounit2-2.0.0
+ >=dev-ml/stdlib-shims-0.2.0"
+
+DOCS=( "README.md" "CHANGES.md" "LICENSE.txt" )
+
+S="${WORKDIR}/${DUNE_PKG_NAME}-v${PV}"
+
+src_prepare() {
+ default
+
+ # Port to dev-ml/ounit2
+ sed -i -e 's/oUnit/ounit2/' test/dune || die
+}