summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-expat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocaml-expat
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocaml-expat')
-rw-r--r--dev-ml/ocaml-expat/Manifest5
-rw-r--r--dev-ml/ocaml-expat/metadata.xml11
-rw-r--r--dev-ml/ocaml-expat/ocaml-expat-1.0.0.ebuild46
-rw-r--r--dev-ml/ocaml-expat/ocaml-expat-1.1.0.ebuild46
4 files changed, 108 insertions, 0 deletions
diff --git a/dev-ml/ocaml-expat/Manifest b/dev-ml/ocaml-expat/Manifest
new file mode 100644
index 000000000000..fd16ae20cf09
--- /dev/null
+++ b/dev-ml/ocaml-expat/Manifest
@@ -0,0 +1,5 @@
+DIST ocaml-expat-1.0.0.tar.gz 58149 BLAKE2B 0bd99a8a5eb8f4fe1a04d1d53edc5dc662a51ae880c5297de9dbc93561896e5c3acf3db4b7edc5122a328be4c17fd924a66a2e0e08c9bd74aac704257f5dc569 SHA512 217d602ac8fabf7713dcd8fd274206b81ff467402a9bca5b15b13f3b1d68e8e5f2c2970adeafb2378c0993b39c7d98a420dee07f30ad9eb88fd40665a2f98897
+DIST ocaml-expat-1.1.0.tar.gz 58318 BLAKE2B 137bc65c5c867180ba547de17041bd0f588da395928e92eabef45cdbb76a1d139d7cd0d80d33337e1fbff92c9fa3cab2339c0f340f50f467b8fe7d64cba10b1e SHA512 9407f91f5007d6835643719294d4e4907bfc40464d054911591ce80c31d173ddcc7b06157a19c0d3ddd78775806242dc68aea7847e588ca9fd1909def1df4d23
+EBUILD ocaml-expat-1.0.0.ebuild 799 BLAKE2B 137cc7772f36c526fcd5e87a7334dd91b56810f8dfc90ed1fc6e7caa120234ad872aac22aeecd8c9b011e2b7280ba31610827d90151b2bf381353bceb9b68f86 SHA512 441c8b375de084746533a41b878edb94a5ed5494b080da3ca6c9cb57730388f9e79503e2dee486e5d0807e025fcad7c41f5aca669a4e81c9b181a79eceff3d73
+EBUILD ocaml-expat-1.1.0.ebuild 799 BLAKE2B 137cc7772f36c526fcd5e87a7334dd91b56810f8dfc90ed1fc6e7caa120234ad872aac22aeecd8c9b011e2b7280ba31610827d90151b2bf381353bceb9b68f86 SHA512 441c8b375de084746533a41b878edb94a5ed5494b080da3ca6c9cb57730388f9e79503e2dee486e5d0807e025fcad7c41f5aca669a4e81c9b181a79eceff3d73
+MISC metadata.xml 344 BLAKE2B 7968da004efd860ae18b16dc89e80d5fdc070761be64a4a4ab02f70b50bc8defff894f87371e8ff271b629a92dc94a2df7adcad166c14b94a1e6bfdbfd12fa45 SHA512 55896d776b185342170d38e2b36d98359a9bbab592f7740bf0d8de90d3cb8a6184381e824a2dcb22e8497b2d4322362770b538a55c0d3f6cb64cc81f7f58303c
diff --git a/dev-ml/ocaml-expat/metadata.xml b/dev-ml/ocaml-expat/metadata.xml
new file mode 100644
index 000000000000..6b7290909864
--- /dev/null
+++ b/dev-ml/ocaml-expat/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">whitequark/ocaml-expat</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-expat/ocaml-expat-1.0.0.ebuild b/dev-ml/ocaml-expat/ocaml-expat-1.0.0.ebuild
new file mode 100644
index 000000000000..00eeb198ef8d
--- /dev/null
+++ b/dev-ml/ocaml-expat/ocaml-expat-1.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+IUSE="doc +ocamlopt test"
+
+DESCRIPTION="OCaml bindings for expat"
+SRC_URI="https://github.com/whitequark/ocaml-expat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/whitequark/ocaml-expat"
+
+RDEPEND="dev-libs/expat
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]"
+
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"
+
+SLOT="0/${PV}"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+src_compile() {
+ emake depend
+ emake all
+ if use ocamlopt; then
+ emake allopt
+ fi
+}
+
+src_test() {
+ emake test
+ if use ocamlopt; then
+ emake testopt
+ fi
+}
+src_install() {
+ findlib_src_preinst
+ emake install
+
+ if use doc ; then
+ dohtml -r doc/html/*
+ fi
+ dodoc README
+}
diff --git a/dev-ml/ocaml-expat/ocaml-expat-1.1.0.ebuild b/dev-ml/ocaml-expat/ocaml-expat-1.1.0.ebuild
new file mode 100644
index 000000000000..00eeb198ef8d
--- /dev/null
+++ b/dev-ml/ocaml-expat/ocaml-expat-1.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+IUSE="doc +ocamlopt test"
+
+DESCRIPTION="OCaml bindings for expat"
+SRC_URI="https://github.com/whitequark/ocaml-expat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/whitequark/ocaml-expat"
+
+RDEPEND="dev-libs/expat
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]"
+
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"
+
+SLOT="0/${PV}"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+src_compile() {
+ emake depend
+ emake all
+ if use ocamlopt; then
+ emake allopt
+ fi
+}
+
+src_test() {
+ emake test
+ if use ocamlopt; then
+ emake testopt
+ fi
+}
+src_install() {
+ findlib_src_preinst
+ emake install
+
+ if use doc ; then
+ dohtml -r doc/html/*
+ fi
+ dodoc README
+}