summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-expat/ocaml-expat-1.1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ml/ocaml-expat/ocaml-expat-1.1.0-r1.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ml/ocaml-expat/ocaml-expat-1.1.0-r1.ebuild')
-rw-r--r--dev-ml/ocaml-expat/ocaml-expat-1.1.0-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-ml/ocaml-expat/ocaml-expat-1.1.0-r1.ebuild b/dev-ml/ocaml-expat/ocaml-expat-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..dbb092201584
--- /dev/null
+++ b/dev-ml/ocaml-expat/ocaml-expat-1.1.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+IUSE="doc +ocamlopt test"
+RESTRICT="!test? ( test )"
+
+DESCRIPTION="OCaml bindings for expat"
+SRC_URI="https://github.com/whitequark/ocaml-expat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/whitequark/ocaml-expat"
+
+RDEPEND="dev-libs/expat
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]"
+
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit2 )"
+
+SLOT="0/${PV}"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+PATCHES=( "${FILESDIR}/ounit2.patch" )
+
+src_compile() {
+ emake depend
+ emake all
+ if use ocamlopt; then
+ emake allopt
+ fi
+ if use doc; then
+ emake doc
+ fi
+}
+
+src_test() {
+ emake test
+ if use ocamlopt; then
+ emake testopt
+ fi
+}
+src_install() {
+ findlib_src_preinst
+ emake install
+
+ if use doc ; then
+ docinto html
+ dodoc -r doc/*
+ fi
+ dodoc README
+}