summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-ctypes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-ml/ocaml-ctypes
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-ml/ocaml-ctypes')
-rw-r--r--dev-ml/ocaml-ctypes/Manifest2
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ctypes/Manifest b/dev-ml/ocaml-ctypes/Manifest
index 32a4c8cae3d4..73347206f883 100644
--- a/dev-ml/ocaml-ctypes/Manifest
+++ b/dev-ml/ocaml-ctypes/Manifest
@@ -1,5 +1,7 @@
DIST ocaml-ctypes-0.17.1.tar.gz 208101 BLAKE2B b9fe6632058a670c988ba9f1ae81b75aa5373de7231cef04d5e2ede61a44cbaa0324c04197a0a202847599a9bbe7dccd18fd3279f3f351493aaec4959caf3ada SHA512 1e197009f7e6b29b43944f757e987934337ebfa11bb2ff2ca8ba3ebc607e37cf1259d07a90d7faf4b91b49ee20d5c65357ad305f34ada0a8d336a3904233150e
DIST ocaml-ctypes-0.19.1.tar.gz 206762 BLAKE2B 29b4636e711b9b3ecf3de5d66b796d4d8ddf1109fd7b065666577ce9412e0ef3712f704729dac3b9467ac7ace8f501b90bfc1dc82b86dbe1668e5d13be46741f SHA512 cbf422a2c457b215815a04122d0522ed0f274c5927cecd25951472de6cc6fcd1151b67f95d6bbfeeb3b5f15a9fe9bdedb8861e77bd0de9902418962065e4dfc0
+DIST ocaml-ctypes-0.20.0.tar.gz 206559 BLAKE2B d9bf1c3f5ae7544e3950766f7eb9bac2c9dbf84130f69b2b8807e55c6a7d659c46d9ba2227d53d578e4e49283730932213eea4c7487beffe4540432b3e700c81 SHA512 605ae95b0233f1157749475526ef00ade2f97649d06a782e8fcf97b604cb86a0dcc8f27c4ac6baec11a41b9ef5becb0e5ae55e30f1ee61b30d4ae17a0d1545c2
EBUILD ocaml-ctypes-0.17.1-r1.ebuild 800 BLAKE2B 4df19810dd960c6d51525dde9dc2b374e7ffed06102bdb6622c847b621e699caba711e3b1ca06ea4daeeb87fb7ec05c0c3a41c8b58120ce658633ffeacd8fd09 SHA512 2239d8cef4ce0c401be0422dd8daf73de29322228ad7764c5d0e2d558bdbfc65d77728a97ff2a7987bb502a45ba8774108ec7f18f247d8dd31d22af4068b4786
EBUILD ocaml-ctypes-0.19.1.ebuild 841 BLAKE2B a13472220bd45c00cab17a197e067a1b9861147ddb9019ca209f998eff0f77a91bd701bf391aab793c0c350fb6c5e75cda0329a9b8bfdcda30e6d8890d6544c7 SHA512 52f29832455b171d001393a03e211c98f665fb828c43c8922cb0a814620d2d2ab6d9f3e1458e7c940652e59c2c9d4fb598ea27e4db3d971883a67a007eae6db9
+EBUILD ocaml-ctypes-0.20.0.ebuild 841 BLAKE2B 2a4b1d2140282915dee375ec410961b94b8200c01380d52383c36676f50ebfb3b90658eecc67263d0bc1ddf5b05fc6454e30c8fc10718f9350a66d78da458427 SHA512 607f81b53328d7f50d18044f9364f15cd10fe28ad502b45b30527a286ff5f9a708b289fa4df2ca34012397bf9a891506b87da68b1a8e7181c9ca646d573f988a
MISC metadata.xml 425 BLAKE2B 3bdffed177ca8fc13a9f6428824f1a97e646449037b4fa5b8053b68edd66c7c8c6bef3c7bb1135e4d76ec42812059408195c3a9cdd45573e571576175e3c9add SHA512 6bd73ddc160b2c5ba8f0630e7aa1045992ff77ece38df06538a2b6b49206c51b14abbcd27367d1b7fe9b192ebf11736e6f0e60dce8df6d475d7a4986edd2547b
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.0.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.0.ebuild
new file mode 100644
index 000000000000..22dbf916bf59
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02:=[ocamlopt]
+ >=dev-libs/libffi-3.3_rc0:=
+ dev-ml/bigarray-compat:=
+ dev-ml/integers:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit2 dev-ml/lwt )"
+
+src_prepare() {
+ sed -e 's/oUnit/ounit2/g' -i Makefile.tests || die
+ default
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.md README.md
+}