summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-cstruct
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-ml/ocaml-cstruct
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-ml/ocaml-cstruct')
-rw-r--r--dev-ml/ocaml-cstruct/Manifest3
-rw-r--r--dev-ml/ocaml-cstruct/metadata.xml16
-rw-r--r--dev-ml/ocaml-cstruct/ocaml-cstruct-3.1.1.ebuild65
3 files changed, 0 insertions, 84 deletions
diff --git a/dev-ml/ocaml-cstruct/Manifest b/dev-ml/ocaml-cstruct/Manifest
deleted file mode 100644
index 0b92c30a2fb3..000000000000
--- a/dev-ml/ocaml-cstruct/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST ocaml-cstruct-3.1.1.tar.gz 208725 BLAKE2B 2818c5695c4ab3d102cfa08a288e80e80d7fa4372a5d97aac831429f0681e21cb6b03baac245c7c1171a8efa23b8d6bca661ee74db0efe8c2649727d9be56505 SHA512 22ec8fe027dbebee537ff950c2aa9a494d0c4c000d8c4df848eae157b1c9502b73c208bb92c21fa4c13ba0291b7750de31e4c96b3a0571397402f841c3e01c21
-EBUILD ocaml-cstruct-3.1.1.ebuild 1310 BLAKE2B 0f79a924f5ac8c592cd259006b7b9ef1d0b4fb8d41e62c26b5eded4f9875e9ebe270e7b09ed0c568fe5f9864a61c62e9be3b59b5c5694ee5c25efe0d5ebfba85 SHA512 8889959da1352e25ab00385203aaf6aa9c5e96cc62a5aa4a81f84b57a0e6cdc287c623a14c2bdc69f145b856b24b9dcac6fe506e2ff7975da941dc961f671250
-MISC metadata.xml 502 BLAKE2B 27898a3a1e0255b8d0c418ea7b894fa9f6781884058031105ddd18f6716653e987faf4b9a9becc8780151b3b266e86574d47de164c932ee3e328ca358779be2d SHA512 16d2014f54ed982f55d27f6eb8be4cbc7ce139a686b93f7a2f35edcbd35264aadf978577eacafb3786ad79f440c159549f21f198b89a06f400ac458ddddbfecb
diff --git a/dev-ml/ocaml-cstruct/metadata.xml b/dev-ml/ocaml-cstruct/metadata.xml
deleted file mode 100644
index ff9cc5cb9108..000000000000
--- a/dev-ml/ocaml-cstruct/metadata.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ml@gentoo.org</email>
- <name>ML</name>
- </maintainer>
- <use>
- <flag name="async">Support for asynchronous execution</flag>
- <flag name="lwt">Enable threads via lwt</flag>
- <flag name="ppx">Enable the ppx syntax extension</flag>
- </use>
- <upstream>
- <remote-id type="github">mirage/ocaml-cstruct</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-ml/ocaml-cstruct/ocaml-cstruct-3.1.1.ebuild b/dev-ml/ocaml-cstruct/ocaml-cstruct-3.1.1.ebuild
deleted file mode 100644
index f766d6e0c4f8..000000000000
--- a/dev-ml/ocaml-cstruct/ocaml-cstruct-3.1.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit findlib opam
-
-DESCRIPTION="Map OCaml arrays onto C-like structs"
-HOMEPAGE="https://github.com/mirage/ocaml-cstruct https://mirage.io"
-SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="async +lwt +ppx test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- async? (
- dev-ml/async_kernel:=
- dev-ml/async_unix:=
- dev-ml/core_kernel:=
- )
- lwt? ( dev-ml/lwt:= )
- ppx? (
- dev-ml/ppx_tools:=
- dev-ml/ocaml-migrate-parsetree:=
- >=dev-ml/ppx_tools_versioned-5.0.1:=
- )
- dev-ml/ocplib-endian:=
- dev-ml/sexplib:=
- dev-ml/type-conv:=
-"
-DEPEND="
- dev-ml/jbuilder
- test? (
- dev-ml/ounit
- ppx? ( dev-ml/ppx_driver dev-ml/ppx_sexp_conv )
- )
- ${RDEPEND}
-"
-
-get_targets() {
- local tgt="cstruct,cstruct-unix"
- use lwt && tgt+=",cstruct-lwt"
- use async && tgt+=",cstruct-async"
- use ppx && tgt+=",ppx_cstruct"
- echo "${tgt}"
-}
-
-src_compile() {
- jbuilder build -p $(get_targets) || die
-}
-
-src_test() {
- jbuilder runtest -p $(get_targets) || die
-}
-
-src_install() {
- opam-install cstruct
- opam-install cstruct-unix
- use lwt && opam-install cstruct-lwt
- use async && opam-install cstruct-async
- use ppx && opam-install ppx_cstruct
-}