summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-crunch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-13 12:26:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-13 12:26:41 +0100
commit482a48c0e1675b1e92663b8b5222bb7261aa7956 (patch)
treeb81e02db1810214fc690a762e3a9c687d0f0c5ab /dev-ml/ocaml-crunch
parent37bccfe5e76c5740c4ef5ba1179e9488d8404075 (diff)
gentoo auto-resync : 13:07:2024 - 12:26:41
Diffstat (limited to 'dev-ml/ocaml-crunch')
-rw-r--r--dev-ml/ocaml-crunch/Manifest3
-rw-r--r--dev-ml/ocaml-crunch/metadata.xml11
-rw-r--r--dev-ml/ocaml-crunch/ocaml-crunch-3.3.1.ebuild24
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/ocaml-crunch/Manifest b/dev-ml/ocaml-crunch/Manifest
new file mode 100644
index 000000000000..39c924e06502
--- /dev/null
+++ b/dev-ml/ocaml-crunch/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-crunch-3.3.1.tar.gz 60602 BLAKE2B 8218c8ca3e0791c5e2857fae4f11b9f9bd1d6687f3b21812762de8fb11c523eceb2bb3470c637509466963bd3c7df5edc6075e79ed900449c03b7fce2b771991 SHA512 9e3fb95d9b592c6463a8c4743419bd100b06727404310089f308705b38a0d3eaa06f58eeaf8b9feef2ec506e4d7035481b3c39b38374d6c1f24903e93aec660b
+EBUILD ocaml-crunch-3.3.1.ebuild 536 BLAKE2B 078e6f060f9d90fa9864adb27ac705b632eda356cb1847182d5497493442b50ef8248cb62cabb1f5c3b0b4cea64a81aa32b9826636f3891f3fbc94faca0d09ec SHA512 3f19acbe7f7365c26f2a601032fa7bc102d0a23ba22f1c90207177253558ec500fa823703e724a27d1ebddaa592ec30267b44eadbf75e620e3649eb515dfa312
+MISC metadata.xml 317 BLAKE2B c4b2283029e5668d511c233bebf0ff097519934cde63e5909645903e187a8b123977112d5fca00be3c8cb36b7dd5076b2c72fb366a16d52850f127b86224c3db SHA512 2f1a99cd82e494d35f8ab3bef6b240eaf79cf5c493b9a5924df5643ad5924a00e129675fd92728f3da4f2e34d1c5667c6768c06c91760885e757fdcd3cb61f7c
diff --git a/dev-ml/ocaml-crunch/metadata.xml b/dev-ml/ocaml-crunch/metadata.xml
new file mode 100644
index 000000000000..52be4be3f2fa
--- /dev/null
+++ b/dev-ml/ocaml-crunch/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mirage/ocaml-crunch</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-crunch/ocaml-crunch-3.3.1.ebuild b/dev-ml/ocaml-crunch/ocaml-crunch-3.3.1.ebuild
new file mode 100644
index 000000000000..02a2c8bbce48
--- /dev/null
+++ b/dev-ml/ocaml-crunch/ocaml-crunch-3.3.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DUNE_PKG_NAME=crunch
+inherit dune
+
+DESCRIPTION="Convert a filesystem into a static OCaml module"
+HOMEPAGE="https://github.com/mirage/ocaml-crunch"
+SRC_URI="https://github.com/mirage/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+DEPEND="
+ dev-ml/cmdliner:=[ocamlopt?]
+ dev-ml/ptime:=[ocamlopt?]
+"
+RDEPEND="${DEPEND}"
+BDEPEND=">=dev-ml/dune-2.5"