summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-conduit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/ocaml-conduit
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/ocaml-conduit')
-rw-r--r--dev-ml/ocaml-conduit/Manifest3
-rw-r--r--dev-ml/ocaml-conduit/metadata.xml11
-rw-r--r--dev-ml/ocaml-conduit/ocaml-conduit-0.15.4.ebuild46
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-ml/ocaml-conduit/Manifest b/dev-ml/ocaml-conduit/Manifest
new file mode 100644
index 000000000000..56983b3e8d36
--- /dev/null
+++ b/dev-ml/ocaml-conduit/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-conduit-0.15.4.tar.gz 38960 SHA256 5c18e1cd034b4f8e0f229426051a16100d30d07c83d7969e3331e0d7dec3b2d7 SHA512 12f61828c943cb60b2c9be080fb32c8fe5ba16d8bac46a8b788f2ea9b8b7a3a53563defbb05271d516365d18cddafe57051125391ac018328608c4f6537ec5b0 WHIRLPOOL 6d82618a68acdee4bb93b18c9a379ecad96ba8d88ebfe600465a7f57ea84b1dfd5cfd7e0f6dcde5f5c76c9395e3e528a9d457d54173a911079daab3ec1064253
+EBUILD ocaml-conduit-0.15.4.ebuild 868 SHA256 33dbb82199ea6e55c3137a6a4f8652d98292c7451330df1ac38f615138d1369a SHA512 a10c6ff240d4f2ea9fd32bf99956d25dbc8e84e733cb0a54f3a631e4ebebb603a13ad19b2724ac7b61e1f43247ad2b95ef00468ec64d410a46efc4bbf7b5435c WHIRLPOOL 53c7532c3ba76feac974fb9408291e8a654236cb7668b9349f968667620d58b9e58b8e104b16c7ceaffdbcabc5e751add879612c0b9cf08712883f3819a307ae
+MISC metadata.xml 332 SHA256 d198c8008cfdbdf479dab1a9f953568f3722850e67e0beeadf1587e42ec165b8 SHA512 66b243700b34216aca33384ebe7dfef68e83b8eb6b755118f56643bdf45f2f83d71db375295b72b52ebacf237849b985ed598fbd0eb52fe1fd58a9f436f2d87a WHIRLPOOL 7866899c6834a8b3629e1fdbba660b20f942e2dfacfba6692e6f25ad984d599c722fe71f2415ba38f1df4b7d079dd7b997f0bad65423a4858b1f963c03f5bb71
diff --git a/dev-ml/ocaml-conduit/metadata.xml b/dev-ml/ocaml-conduit/metadata.xml
new file mode 100644
index 000000000000..06a872f18368
--- /dev/null
+++ b/dev-ml/ocaml-conduit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mirage/ocaml-conduit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-conduit/ocaml-conduit-0.15.4.ebuild b/dev-ml/ocaml-conduit/ocaml-conduit-0.15.4.ebuild
new file mode 100644
index 000000000000..5690ccf9541d
--- /dev/null
+++ b/dev-ml/ocaml-conduit/ocaml-conduit-0.15.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="Dereference URIs into communication channels for Async or Lwt"
+HOMEPAGE="https://github.com/mirage/ocaml-conduit"
+SRC_URI="https://github.com/mirage/ocaml-conduit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/sexplib:=
+ dev-ml/stringext:=
+ dev-ml/ocaml-uri:=
+ dev-ml/logs:=
+ dev-ml/ocaml-cstruct:=
+ dev-ml/ocaml-ipaddr:=
+
+ >=dev-ml/lwt-3:=
+ dev-ml/lwt_ssl:=
+ dev-ml/async:=
+ dev-ml/dns:=
+ dev-ml/ocaml-ssl:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+ dev-ml/ppx_driver
+ dev-ml/ppx_optcomp
+ dev-ml/ppx_sexp_conv
+"
+
+DOCS=( TODO.md README.md CHANGES )
+
+src_install() {
+ findlib_src_preinst
+ default
+}