summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-compiler-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ml/ocaml-compiler-libs
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ml/ocaml-compiler-libs')
-rw-r--r--dev-ml/ocaml-compiler-libs/Manifest4
-rw-r--r--dev-ml/ocaml-compiler-libs/metadata.xml5
-rw-r--r--dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.12.3.ebuild18
3 files changed, 25 insertions, 2 deletions
diff --git a/dev-ml/ocaml-compiler-libs/Manifest b/dev-ml/ocaml-compiler-libs/Manifest
index 91c2ed9668e2..0672d901ddbc 100644
--- a/dev-ml/ocaml-compiler-libs/Manifest
+++ b/dev-ml/ocaml-compiler-libs/Manifest
@@ -1,3 +1,5 @@
+DIST ocaml-compiler-libs-0.12.3.tar.gz 4982 BLAKE2B 83432cbb2707964f025b294a84cdcce77137156e409d85ce8615dd6e9a26ad085cd5de178ebeb7520cd95b19a15b3cfbf7ef9567d165b55e07850a231b68371c SHA512 748ae11fe4cedb12d153ef2e712a9899f6a7ab4a35ddb7c95c0ae25af979c3edf274046745dddb2253fc06be41d5b0029f11a5a823a17d1ee680ffb29c4bdc89
DIST ocaml-compiler-libs-0.9.0.tar.gz 6937 BLAKE2B d53a8312ffabfed0b137d435497b4d7953239f57176481f522cbb70fd49a1a8045850d7572830455aefff1a91c6c461c03f40392b386bacb03afda3f72e39005 SHA512 ee0751bcfb9cb75d272f7af4f7da184c0a8e348384a2481da9dea0245a4133de908a23d0a324e0353397a4f0c5bfd71d40a6a46dbd8e4acea922bad7cdc5ef64
+EBUILD ocaml-compiler-libs-0.12.3.ebuild 511 BLAKE2B e686fa23f7998dd096cd6a041a944b82c6a1ea85523747abb5176b665f063a8c3b868b00c0dc827be153851fce65e2e77d1783abaf2aa9dfafff8fac1b0460a7 SHA512 46c5e8ea62c35a9ae7b822c62834a13651fdfc0947a846c79c5f109e772c2cac20afa8d7ed0c96a72f54f59ab562da329ac53643bc97c70a8382fdef215cc2ba
EBUILD ocaml-compiler-libs-0.9.0.ebuild 503 BLAKE2B 33c52b9fcc53493a2ff3ccf0382727a646ea1f22c1584bafad31be9167e581003986d58cd25693d1d933fbbf92cdc1ce3aa5ece8ad300a7d4d70f9f982283b60 SHA512 0dbffb4360a13f62719e16ca2487eca8c09bca5ea1b32fe7f1608790c92e46d4a56f5693cfe697cf9df6369cc450a7c0df5d70d4ce820829b71cb65485042838
-MISC metadata.xml 262 BLAKE2B d7304653f48782c8efacafb545457ea98b6b4b2570591a8866e37d37e68c7d002868e0b5421143bad4a94a796131c268d1ed59c2ea72cc41a91ea26065aa359c SHA512 bf2d79c33f71e2966ce79323c84e33ad8d8aed07c32dada1b7e1ef851ebef6f94f5bccd2c9bba1cb3b78ea31a2b4ddfe0eacea85e9a2d9fe4691b849600f7825
+MISC metadata.xml 339 BLAKE2B a88542e3c94246704d78ae7795166cee13f24054bb39450b2c1b7f3c499514e67fcf38421100c96ca597115bf354a1e20290d22d57fa9313bfb6279020c2758e SHA512 5480f0fa988de348557ae888609a48a083798d9d4decb57e6b29c3789e83b4900a663ba15ef9cbf3c2574404046e4b1101026369355db6cdfdda8291a1eca0e5
diff --git a/dev-ml/ocaml-compiler-libs/metadata.xml b/dev-ml/ocaml-compiler-libs/metadata.xml
index b15fbc969a48..386b3cb8e9bc 100644
--- a/dev-ml/ocaml-compiler-libs/metadata.xml
+++ b/dev-ml/ocaml-compiler-libs/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
<upstream>
<remote-id type="github">janestreet/ocaml-compiler-libs</remote-id>
</upstream>
diff --git a/dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.12.3.ebuild b/dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.12.3.ebuild
new file mode 100644
index 000000000000..c298ee7aa979
--- /dev/null
+++ b/dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.12.3.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Repackage the OCaml compiler libs so they do not expose everything at toplevel"
+HOMEPAGE="https://github.com/janestreet/ocaml-compiler-libs"
+SRC_URI="https://github.com/janestreet/ocaml-compiler-libs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"