summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-compiler-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/ocaml-compiler-libs
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/ocaml-compiler-libs')
-rw-r--r--dev-ml/ocaml-compiler-libs/Manifest3
-rw-r--r--dev-ml/ocaml-compiler-libs/metadata.xml11
-rw-r--r--dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.9.0.ebuild19
3 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/ocaml-compiler-libs/Manifest b/dev-ml/ocaml-compiler-libs/Manifest
new file mode 100644
index 000000000000..e314792625ee
--- /dev/null
+++ b/dev-ml/ocaml-compiler-libs/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-compiler-libs-0.9.0.tar.gz 6937 SHA256 74944fba8a66966aa73366d030aa01b631856b73e26bbb0aa81ffa9e774ceed8 SHA512 ee0751bcfb9cb75d272f7af4f7da184c0a8e348384a2481da9dea0245a4133de908a23d0a324e0353397a4f0c5bfd71d40a6a46dbd8e4acea922bad7cdc5ef64 WHIRLPOOL 3c051095613ed1faede5f77e73a289cc17091d6d7455ed96491a3c4f25ceda1057691ebbee24b390e401b9ecb5344e9edf135e4906f648a6aa27cd9e38e1cd2e
+EBUILD ocaml-compiler-libs-0.9.0.ebuild 498 SHA256 c7c3eff2366eac80a83083777ce2c2c113b03f7f6be8914de8bb8438ea9bbb7b SHA512 f5ca87489181798f8e5766fb54f5c1770e00acdac58404e28af2d603c3b870760e83f31ea8e4206bf56652214168334321eb78aad86e893f1114cdcb00dc0c18 WHIRLPOOL 317f759d89cffd960d928412f3510c861a9176233847203334dd75f8d21ae487f8e98eae5f3f265cddd31deb10a30820625d18d97150c8be93771a8d6c1bdd15
+MISC metadata.xml 342 SHA256 dc37ec7677c99f946b3fe854f797abd86526d0be54563b470a6a3d9078d648d9 SHA512 6fc014610d8008f2215be854a93d1e2ea5759be991f7e107cbc38e5f754cdfde4ae770ee654163da88ffd1e071364e5562fd8e6aade66803f0dee7d103968d29 WHIRLPOOL 7d47a70e4d55147bb1b2ff96b587b98c2464cc452a43a7393fcea3bc17281f370bd919a669d0183593a3ffa89e62fa46191379cfc40170feae2199996cc5489d
diff --git a/dev-ml/ocaml-compiler-libs/metadata.xml b/dev-ml/ocaml-compiler-libs/metadata.xml
new file mode 100644
index 000000000000..9edbba42aa69
--- /dev/null
+++ b/dev-ml/ocaml-compiler-libs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">janestreet/ocaml-compiler-libs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.9.0.ebuild b/dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.9.0.ebuild
new file mode 100644
index 000000000000..82cd4f1c3a94
--- /dev/null
+++ b/dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.9.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit opam
+
+DESCRIPTION="Repackage the OCaml compiler libs so they do not expose everything at toplevel"
+HOMEPAGE="https://github.com/janestreet/ocaml-compiler-libs"
+SRC_URI="https://github.com/janestreet/ocaml-compiler-libs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder"