summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-cohttp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocaml-cohttp
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocaml-cohttp')
-rw-r--r--dev-ml/ocaml-cohttp/Manifest3
-rw-r--r--dev-ml/ocaml-cohttp/metadata.xml15
-rw-r--r--dev-ml/ocaml-cohttp/ocaml-cohttp-0.22.0.ebuild62
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-ml/ocaml-cohttp/Manifest b/dev-ml/ocaml-cohttp/Manifest
new file mode 100644
index 000000000000..7b39db74abd5
--- /dev/null
+++ b/dev-ml/ocaml-cohttp/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-cohttp-0.22.0.tar.gz 194568 BLAKE2B 220c291cdf50c1720e553cc224f6b3c7723add13a637cedd33deb162d4f420a8577b716f073c2b6a630de4458bdc9ac69d8eeeb1ccd44cb310b1a1262188c680 SHA512 60ae828a3e2085d5468f5d177f50a8e7a02ed47b8036af5548996ba3d36d8eef756662259abc65035c5d1f4158c9760762ac5f85376d6bfc76a7f027f01fa5b2
+EBUILD ocaml-cohttp-0.22.0.ebuild 1204 BLAKE2B e816d4c682a6558f112becb249574df5373d80fd76c6ca6ed9abf6f448707674461e80f0ccd655352ab66371e43bcf2e8e17170785334d7a861b61a91e79c478 SHA512 9e6d2156ff1a41800b22aee74a9cc171b8322b156f2ead735532ad710b43697fc350bc26558e2e964727bc967a696a743515225c2f839d2ff0d0b0c9eed63a89
+MISC metadata.xml 567 BLAKE2B d8bd4fef986fb074d741550341df612bb69790dae6807bda2b6ce3aae2bd481550ec27ba3a685fc18d26ba6f5fc62383f095dbd6ab0ec5621b2f25c990106364 SHA512 6f139e3724deb005b008c56149bdad83a7fa145cc32e72586e097aa2c435ce65a21cfe0a37dfbd5848670d03fbc10121f55c5414970c92baba69115099c3bea0
diff --git a/dev-ml/ocaml-cohttp/metadata.xml b/dev-ml/ocaml-cohttp/metadata.xml
new file mode 100644
index 000000000000..01cbb468ae34
--- /dev/null
+++ b/dev-ml/ocaml-cohttp/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <use>
+ <flag name="async">Enables support for the <pkg>dev-ml/async</pkg> asynchronous execution library.</flag>
+ <flag name="lwt">Enables support for the <pkg>dev-ml/lwt</pkg> cooperative light-weight thread library.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">mirage/ocaml-cohttp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-cohttp/ocaml-cohttp-0.22.0.ebuild b/dev-ml/ocaml-cohttp/ocaml-cohttp-0.22.0.ebuild
new file mode 100644
index 000000000000..bb00e40e1629
--- /dev/null
+++ b/dev-ml/ocaml-cohttp/ocaml-cohttp-0.22.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Very lightweight HTTP server using Lwt or Async"
+HOMEPAGE="https://github.com/mirage/ocaml-cohttp"
+SRC_URI="https://github.com/mirage/ocaml-cohttp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async javascript +lwt"
+
+DEPEND="
+ dev-ml/ocaml-re:=
+ dev-ml/stringext:=
+ dev-ml/ocaml-uri:=
+ dev-ml/fieldslib:=
+ dev-ml/sexplib:=
+ dev-ml/ppx_fields_conv:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/ocaml-base64:=
+ lwt? (
+ dev-ml/lwt:=
+ dev-ml/logs:=[fmt,lwt]
+ dev-ml/cmdliner:=
+ dev-ml/ocaml-conduit:=
+ dev-ml/ocaml-magic-mime:=
+ )
+ async? (
+ dev-ml/ocaml-conduit:=
+ dev-ml/logs:=[fmt]
+ dev-ml/ocaml-magic-mime:=
+ dev-ml/fmt:=
+ )
+ javascript? (
+ dev-ml/js_of_ocaml:=[ppx]
+ )
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ test? (
+ dev-ml/ounit
+ dev-ml/alcotest
+ )
+"
+DOCS=( README.md CHANGES DESIGN.md TODO.md )
+
+src_configure() {
+ local oasis_configure_opts="
+ $(use_enable lwt) $(use_enable lwt lwt-unix)
+ $(use_enable async)
+ $(use_enable javascript js)
+ "
+ oasis_src_configure
+}