summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-bigstring
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocaml-bigstring
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocaml-bigstring')
-rw-r--r--dev-ml/ocaml-bigstring/Manifest3
-rw-r--r--dev-ml/ocaml-bigstring/metadata.xml11
-rw-r--r--dev-ml/ocaml-bigstring/ocaml-bigstring-0.1.1.ebuild31
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ml/ocaml-bigstring/Manifest b/dev-ml/ocaml-bigstring/Manifest
new file mode 100644
index 000000000000..81473819da85
--- /dev/null
+++ b/dev-ml/ocaml-bigstring/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-bigstring-0.1.1.tar.gz 7671 BLAKE2B 2754445a2eb6d2cfe52a07cdf55b970c736d007578962be730bdac3c793981565a3ba64b7429cae532aee21f72ae7f5cefabbecf554c6238fad791c45e4fc200 SHA512 96aee494b9407b556b6eb554b0da66e24622f77d88aae6d822da60a3fb21477da8e7ae120f95f4f3c742b085ca4838f10ca0c8b2bcc4d23e35fd7de6af8532b3
+EBUILD ocaml-bigstring-0.1.1.ebuild 587 BLAKE2B 8ea1bb18545b00387ebca4ecaa9fc564886ddb46c9cc2ccbdaa6f7a26422c59d8d854c63214627e36c51f4909341a96ecd4b96e631f125b017ad577a5228a3cd SHA512 eaedd972b16651dc798fbdd74fd74f96257cca2237e530eb751bfbcf9a4281ab75669aec8ae3d098a802dbc696b16eee633b32a7b7d25242eb59de70556c8416
+MISC metadata.xml 334 BLAKE2B c34682734b68db6fe5563dde2d9c15177a9107d47e5a69f81d0864afa682b77b723cdf0737fd5cf74ea36b699fbd2b577016024288ed1d86eddb528792336fbe SHA512 abeb551e902ab6b403cf0b8b4fe5d5b405cbbbfc64cc47e39793cdfb554f45e04e10a306ff0de097ba7154e739a397575ce1fb8833cc84cebaabd16d78f20314
diff --git a/dev-ml/ocaml-bigstring/metadata.xml b/dev-ml/ocaml-bigstring/metadata.xml
new file mode 100644
index 000000000000..2e4acd905351
--- /dev/null
+++ b/dev-ml/ocaml-bigstring/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">c-cube/ocaml-bigstring</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-bigstring/ocaml-bigstring-0.1.1.ebuild b/dev-ml/ocaml-bigstring/ocaml-bigstring-0.1.1.ebuild
new file mode 100644
index 000000000000..84098f18ecbe
--- /dev/null
+++ b/dev-ml/ocaml-bigstring/ocaml-bigstring-0.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="Overlay over bigarrays of chars"
+HOMEPAGE="https://github.com/c-cube/ocaml-bigstring/"
+SRC_URI="https://github.com/c-cube/ocaml-bigstring/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+# ocamlfind: Package `QTest2Lib' not found
+RESTRICT="test"
+
+RDEPEND="
+ dev-lang/ocaml:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/ocamlbuild
+ test? ( dev-ml/iTeML )
+"
+
+src_install() {
+ findlib_src_preinst
+ default
+}