summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-bigstring
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/ocaml-bigstring
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/ocaml-bigstring')
-rw-r--r--dev-ml/ocaml-bigstring/Manifest3
-rw-r--r--dev-ml/ocaml-bigstring/metadata.xml11
-rw-r--r--dev-ml/ocaml-bigstring/ocaml-bigstring-0.1.1.ebuild31
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ml/ocaml-bigstring/Manifest b/dev-ml/ocaml-bigstring/Manifest
new file mode 100644
index 000000000000..483082c29136
--- /dev/null
+++ b/dev-ml/ocaml-bigstring/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-bigstring-0.1.1.tar.gz 7671 SHA256 d09dad10711d5bf4e48601e09702186f5c1d12c7772e44e3ab9394d3839f2b27 SHA512 96aee494b9407b556b6eb554b0da66e24622f77d88aae6d822da60a3fb21477da8e7ae120f95f4f3c742b085ca4838f10ca0c8b2bcc4d23e35fd7de6af8532b3 WHIRLPOOL 59d3c570b024f292122052e9bbc9a8306032250cd95ecc18f9fcf6ebdf89ebc7db0060825cae18ad2271f99d75c1713d176a8b9bd1a457193f77d976aad49333
+EBUILD ocaml-bigstring-0.1.1.ebuild 587 SHA256 eb73eadd947e21b4ae0b7f5f2061e71cbe3c4e2cf700c3619dd5bee76719cad5 SHA512 eaedd972b16651dc798fbdd74fd74f96257cca2237e530eb751bfbcf9a4281ab75669aec8ae3d098a802dbc696b16eee633b32a7b7d25242eb59de70556c8416 WHIRLPOOL 7bf4264b9f68f346c7efe0c5f6093664b6d3b1668c4f3c3fc138019cfe2cadaf82d7be510f394cd66863bc5ff5ca7150018b87ccb16152966f10f94688618972
+MISC metadata.xml 334 SHA256 e56433674934d96768b61ee41660c8cbb400662433d257035febfea58072ba1b SHA512 abeb551e902ab6b403cf0b8b4fe5d5b405cbbbfc64cc47e39793cdfb554f45e04e10a306ff0de097ba7154e739a397575ce1fb8833cc84cebaabd16d78f20314 WHIRLPOOL 9de248aa792c4df4ad02faac140fa398503cd34ee354b0624d7af7cb90d6406d35fbacd6d535f61da0d28b8f73cca0a48b68ea0e695a26ad4e7faa9062f409e4
diff --git a/dev-ml/ocaml-bigstring/metadata.xml b/dev-ml/ocaml-bigstring/metadata.xml
new file mode 100644
index 000000000000..2e4acd905351
--- /dev/null
+++ b/dev-ml/ocaml-bigstring/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">c-cube/ocaml-bigstring</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-bigstring/ocaml-bigstring-0.1.1.ebuild b/dev-ml/ocaml-bigstring/ocaml-bigstring-0.1.1.ebuild
new file mode 100644
index 000000000000..84098f18ecbe
--- /dev/null
+++ b/dev-ml/ocaml-bigstring/ocaml-bigstring-0.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="Overlay over bigarrays of chars"
+HOMEPAGE="https://github.com/c-cube/ocaml-bigstring/"
+SRC_URI="https://github.com/c-cube/ocaml-bigstring/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+# ocamlfind: Package `QTest2Lib' not found
+RESTRICT="test"
+
+RDEPEND="
+ dev-lang/ocaml:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/ocamlbuild
+ test? ( dev-ml/iTeML )
+"
+
+src_install() {
+ findlib_src_preinst
+ default
+}