summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-base64
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocaml-base64
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocaml-base64')
-rw-r--r--dev-ml/ocaml-base64/Manifest3
-rw-r--r--dev-ml/ocaml-base64/metadata.xml11
-rw-r--r--dev-ml/ocaml-base64/ocaml-base64-2.2.0.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/ocaml-base64/Manifest b/dev-ml/ocaml-base64/Manifest
new file mode 100644
index 000000000000..f3ec7d5abe96
--- /dev/null
+++ b/dev-ml/ocaml-base64/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-base64-2.2.0.tar.gz 5056 BLAKE2B c8a95d31646e5cad741dbece511e3f0fb736c31e5f90b560e2dffe5787810cd218966016840eef0c67517e790d0e4c67111c3382303c740791475647bac27de1 SHA512 0390c450076786777baeb596bc81bc3357074619894334a9608f958a2a10113e22afdbd3a2b368bc93c5c5636828fc2600818399847704309e2cc6092b10f3b0
+EBUILD ocaml-base64-2.2.0.ebuild 544 BLAKE2B 19d5c72a2a532c07d7ee58db7f872ef3accae417b1f989c8a88f877ccc8d1a582c700cb81282f8dc632f1ffc79cc1b0132fc85fd57c72a1ce0ab22fb35af7f87 SHA512 9bb8e3bb9c523f651a8e7fa33d8c92fdc4e03cf5a1926f02077de99002461cfdbfae967fa4f91f2073514fcf64d064ca5ee77e4df063399b1397d572487a74c6
+MISC metadata.xml 341 BLAKE2B 3cdd6a266c1315b4f8c3cd7b1eed18301312ff225ecc4694f1f7648326a7933507e153c59911d4725bda4cce21dd4369ccb4585d755508bd03ec5a7b1d06c7e2 SHA512 64fbfdebb9759fa2af0d070a13c1b7ed9662c095bf1ab78c64e43dae274f52f2b25801544a2a56c942c0d920383673eaf6860fd54335e1c84976ec9a68fc6234
diff --git a/dev-ml/ocaml-base64/metadata.xml b/dev-ml/ocaml-base64/metadata.xml
new file mode 100644
index 000000000000..535fa8d4ec98
--- /dev/null
+++ b/dev-ml/ocaml-base64/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mirage/ocaml-base64</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-base64/ocaml-base64-2.2.0.ebuild b/dev-ml/ocaml-base64/ocaml-base64-2.2.0.ebuild
new file mode 100644
index 000000000000..35d4f2abf2bf
--- /dev/null
+++ b/dev-ml/ocaml-base64/ocaml-base64-2.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit findlib opam
+
+DESCRIPTION="Library for radix-64 representation (de)coding"
+HOMEPAGE="https://github.com/mirage/ocaml-base64"
+SRC_URI="https://github.com/mirage/ocaml-base64/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ test? ( dev-ml/rresult dev-ml/bos dev-ml/alcotest )
+"
+
+src_install() {
+ opam_src_install base64
+}