summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-augeas/ocaml-augeas-0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-26 15:55:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-26 15:55:57 +0100
commit533ce9c954925ca2a6bccd1f52f266e81e61a678 (patch)
treeef0ef849f69e60394f4bbbab166e6b83848f609c /dev-ml/ocaml-augeas/ocaml-augeas-0.6.ebuild
parent9a8514e070a40648dbc8e28ad6457d925542b79a (diff)
gentoo auto-resync : 26:10:2022 - 15:55:57
Diffstat (limited to 'dev-ml/ocaml-augeas/ocaml-augeas-0.6.ebuild')
-rw-r--r--dev-ml/ocaml-augeas/ocaml-augeas-0.6.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/ocaml-augeas/ocaml-augeas-0.6.ebuild b/dev-ml/ocaml-augeas/ocaml-augeas-0.6.ebuild
new file mode 100644
index 000000000000..86d56ae426d5
--- /dev/null
+++ b/dev-ml/ocaml-augeas/ocaml-augeas-0.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit findlib
+
+DESCRIPTION="Ocaml bindings for Augeas"
+HOMEPAGE="http://augeas.net/"
+#SRC_URI="http://augeas.net/download/ocaml/${P}.tar.gz"
+SRC_URI="https://people.redhat.com/~rjones/augeas/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ app-admin/augeas
+ dev-libs/libxml2
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-ml/findlib
+ dev-ml/ocaml-autoconf
+ dev-lang/ocaml[ocamlopt]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-flags.patch
+ "${FILESDIR}"/${P}-ocaml-4.09.patch
+)
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+}