summaryrefslogtreecommitdiff
path: root/dev-ml/oasis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/oasis
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/oasis')
-rw-r--r--dev-ml/oasis/Manifest5
-rw-r--r--dev-ml/oasis/metadata.xml8
-rw-r--r--dev-ml/oasis/oasis-0.4.10.ebuild40
-rw-r--r--dev-ml/oasis/oasis-0.4.8.ebuild38
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-ml/oasis/Manifest b/dev-ml/oasis/Manifest
new file mode 100644
index 000000000000..5a61699a06a7
--- /dev/null
+++ b/dev-ml/oasis/Manifest
@@ -0,0 +1,5 @@
+DIST oasis-0.4.10.tar.gz 394732 BLAKE2B 6347e532d595e33a3a62f63669625d6de0081e8be90568a0e9f334b9745a40ec2593e7c79d21174f3119728c4831393efff0a3ab6d1aeadc594a0f96e5112a72 SHA512 c173a3a774d13a7cb21ddb44f89dadef210d331ab5f3a1e7ff1705e815572f70e22815736cc3f3788b6d8f784c21a309b45c5bf5e984e583b31931847bf107fd
+DIST oasis-0.4.8.tar.gz 389565 BLAKE2B 50103f261fd4c9d11fea1d7c26abc047fd0f30ab17b871672cb1ce0a89fd47d378fd4f31d48f1a6835361ddb74761a0ad9fe4bc5ca514e470a4cf3594f30c762 SHA512 e0baf0f048647c25eac5472db0d2a22d0fcaf85fe61ebd88ec5a101c20d4916ecfa9d10fae069ba4479abb22b90c44f18312b9252727a8c7c7de4aa2d8d72663
+EBUILD oasis-0.4.10.ebuild 934 BLAKE2B d8ffbc2f5e5d3e80e81ed636d1e37e37bc18d11112741f773597763c274029bc7dc2c89c0fee6436c66a2c56bafe270c7276c7b69f74b5e402320a0f651a3154 SHA512 ed409a6005f3accc39d4ee7e59869d8c0a9615ef3510eebdf9e40d8fce0f121139bc902a9cc434b7a2e2b005498342503903e144eade2ad894c346cd33951de4
+EBUILD oasis-0.4.8.ebuild 916 BLAKE2B 60f34a25a418dd0912aeb7506be67204aa15a74b09e149541a6efd721eb9e1ea4a28f7705d975202bfb9c8028dbd938eeaa5b5452582bf36d9635c93f5f0e8de SHA512 038a210bb0d225a6064401b0c4beee4a5f306272f1c48c63e1f6e4cbd666d6fe24704e70023893e1c064d9e26d775bcb9befb0f893c4b11d81bfd14a85695358
+MISC metadata.xml 247 BLAKE2B a49ba320a43edd431ae39eb274b77ddf0db171a7b06f4f0f0b8f75ee8e3b7f840dead108aa9c63fba75c609a44f7418268cd65c65877f3305d2a6d3ed3c678f6 SHA512 0f7ebd1264695f56fe6ab78e4e82c07866376f03ebfa12b22b60d0b2df819aa818832cb0d9eb2d77ab642a786b44cd127f579c348f0b2f57bc22e26b3b51c42b
diff --git a/dev-ml/oasis/metadata.xml b/dev-ml/oasis/metadata.xml
new file mode 100644
index 000000000000..75c9ea74812d
--- /dev/null
+++ b/dev-ml/oasis/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-ml/oasis/oasis-0.4.10.ebuild b/dev-ml/oasis/oasis-0.4.10.ebuild
new file mode 100644
index 000000000000..03927db12119
--- /dev/null
+++ b/dev-ml/oasis/oasis-0.4.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${P/_/\~}
+DESCRIPTION="Tool to integrate a configure, build and install system in OCaml project"
+HOMEPAGE="http://oasis.forge.ocamlcore.org/index.php"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1694/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-ml/ocaml-data-notation-0.0.11:=
+ dev-ml/ocamlbuild:=[ocamlopt]
+ dev-ml/camlp4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-ml/findlib-1.3.1
+ dev-ml/ocamlify
+ dev-ml/ocamlmod
+ !<sci-chemistry/oasis-4.0-r3
+ test? (
+ >=dev-ml/ocaml-fileutils-0.4.2
+ >=dev-ml/ounit-2.0.0
+ >=dev-ml/ocaml-expect-0.0.4
+ dev-ml/pcre-ocaml
+ dev-ml/extlib
+ )"
+
+STRIP_MASK="*/bin/*"
+S="${WORKDIR}/${MY_P}"
+DOCS=( "README.md" "TODO.txt" "AUTHORS.md" "CHANGES.txt" )
diff --git a/dev-ml/oasis/oasis-0.4.8.ebuild b/dev-ml/oasis/oasis-0.4.8.ebuild
new file mode 100644
index 000000000000..e2f5056918fe
--- /dev/null
+++ b/dev-ml/oasis/oasis-0.4.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${P/_/\~}
+DESCRIPTION="Tool to integrate a configure, build and install system in OCaml project"
+HOMEPAGE="http://oasis.forge.ocamlcore.org/index.php"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1669/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-ml/ocaml-data-notation-0.0.11:=
+ dev-ml/ocamlbuild:=[ocamlopt]"
+DEPEND="${RDEPEND}
+ >=dev-ml/findlib-1.3.1
+ dev-ml/ocamlify
+ dev-ml/ocamlmod
+ !<sci-chemistry/oasis-4.0-r3
+ test? (
+ >=dev-ml/ocaml-fileutils-0.4.2
+ >=dev-ml/ounit-2.0.0
+ >=dev-ml/ocaml-expect-0.0.4
+ dev-ml/pcre-ocaml
+ dev-ml/extlib
+ )"
+
+STRIP_MASK="*/bin/*"
+S="${WORKDIR}/${MY_P}"
+DOCS=( "README.md" "TODO.txt" "AUTHORS.md" "CHANGES.txt" )