summaryrefslogtreecommitdiff
path: root/dev-ml/mtime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /dev-ml/mtime
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'dev-ml/mtime')
-rw-r--r--dev-ml/mtime/Manifest2
-rw-r--r--dev-ml/mtime/mtime-1.2.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/mtime/Manifest b/dev-ml/mtime/Manifest
index 279492b8edaa..d3d9615e5c37 100644
--- a/dev-ml/mtime/Manifest
+++ b/dev-ml/mtime/Manifest
@@ -1,3 +1,5 @@
DIST mtime-1.1.0.tbz 15467 BLAKE2B 975fdb01c6a4806035a5fbc256d192d6c2f45bdfb750045293b10a732c5613108d9bce897d3c1be660af60d6e9bafbf299dedbc0d872d1c09f65f47b11c9a6b6 SHA512 8ed5dae589dd27fc6e748218a9d9fb9d7d954d231fc2100d61c1b336e0ed38a215bc608cdea9965547729177c78c868c1de6a5ceac6735686a3de1c4a791746c
+DIST mtime-1.2.0.tbz 16272 BLAKE2B 317201f8d5e7a55636e58748ffd269db5e88aed012e8dd7ed269d1f128f8d21ed0e707679b030b9c822bac98c9b76033e8d2402171c4ee758d8c936fbeee7ee9 SHA512 0f0ed220cd0f899643930814010f8592e1f47b6dc6c4dce8eebfb17a81b0abed093a3dbf9c02490af99bf81ea640372f73b4ab88fd8ef0e0c7c66920692a8778
EBUILD mtime-1.1.0.ebuild 717 BLAKE2B d49774f2eb6d262680e3f0bd929ad61a91a16913864361d374188004c2ebd5c52ebefaae73d1b5a38c588a258fbd317f612f83392a32bce10b618ccd5c00d40b SHA512 03b1bcd56fa44c53c2e10967fa29a5211057dded1de5554db54cbed83a0dd8d3c9202d8dcddc157f1cdfaf494c9043e628e3777023ffd866b2151948ab12fd10
+EBUILD mtime-1.2.0.ebuild 723 BLAKE2B 3da03fa3bd6a6ddc6621e6ed26cc9cc54e55488ad504b81d5c38b38f68e991631b95aeb8dcd2b60892c729a849fa4a1e0e3fb349d8eaa0e2cafe2a231cac88a0 SHA512 22c755c8c00adac4711d1fecfeb3410688d2ecc022f46f696fc2c711e1f84a0558bb73683116a99f62d880f684895bf33a7d0389bc1260dce2fdbb880bfd7a65
MISC metadata.xml 311 BLAKE2B ec6d4e0813be98a7a30d4e8ca05ac9c74953bb0fa763c7d004ac76f23dfefb8d157784dab7f0d3674a81e840659d16ba4f28ffe3ab6913aa6affefe80b8786eb SHA512 ac2409cb1fcd4b9ba1760c38024a96ac3dccb7337b78e7eff636c23cf7f2aeea22fdec377eb80afedfda0738a2396d511afb1d4f0913fb6e95ab8473a850b9df
diff --git a/dev-ml/mtime/mtime-1.2.0.ebuild b/dev-ml/mtime/mtime-1.2.0.ebuild
new file mode 100644
index 000000000000..a6d491ea6add
--- /dev/null
+++ b/dev-ml/mtime/mtime-1.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="OCaml module to access monotonic wall-clock time"
+HOMEPAGE="https://erratique.ch/software/mtime https://github.com/dbuenzli/mtime"
+SRC_URI="https://erratique.ch/software/mtime/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt]"
+DEPEND="${RDEPEND}
+ dev-ml/topkg
+ dev-ml/ocamlbuild
+ dev-ml/findlib"
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --with-js_of_ocaml false \
+ --tests $(usex test true false) \
+ || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}