summaryrefslogtreecommitdiff
path: root/dev-ml/menhir/menhir-20220210.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-06 22:33:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-06 22:33:57 +0100
commitc4b3d05f2d4415c0d6f135a3ea0d2055d6e055b5 (patch)
tree3ed89f0ec34cf85a0c06c027a6889e7890e08db6 /dev-ml/menhir/menhir-20220210.ebuild
parent8965d348ad07c326c8e17e3137c151bcc98b0a53 (diff)
gentoo auto-resync : 06:09:2022 - 22:33:57
Diffstat (limited to 'dev-ml/menhir/menhir-20220210.ebuild')
-rw-r--r--dev-ml/menhir/menhir-20220210.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ml/menhir/menhir-20220210.ebuild b/dev-ml/menhir/menhir-20220210.ebuild
new file mode 100644
index 000000000000..a7e17e42e5f2
--- /dev/null
+++ b/dev-ml/menhir/menhir-20220210.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="LR(1) parser generator for the OCaml language"
+HOMEPAGE="http://gallium.inria.fr/~fpottier/menhir/"
+SRC_URI="https://gitlab.inria.fr/fpottier/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+src_install() {
+ dune_src_install menhir
+ dune_src_install menhirLib
+ dune_src_install menhirSdk
+}