summaryrefslogtreecommitdiff
path: root/dev-ml/markup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/markup
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/markup')
-rw-r--r--dev-ml/markup/Manifest3
-rw-r--r--dev-ml/markup/markup-0.7.5.ebuild38
-rw-r--r--dev-ml/markup/metadata.xml11
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-ml/markup/Manifest b/dev-ml/markup/Manifest
new file mode 100644
index 000000000000..14a6e8914e8a
--- /dev/null
+++ b/dev-ml/markup/Manifest
@@ -0,0 +1,3 @@
+DIST markup-0.7.5.tar.gz 278654 BLAKE2B 5338d4b546c74ade522c84c5a0583ad08b09e4ca3ecb96712725dd33792e401f66f076e47cf24986047f36236c53134272cadcd2abe322307377bb79055bf39a SHA512 19350df7a3a619c479fa030b8772009bc32f3e9830494f5707e05f85b9ee9ff0ddf382d292c7a11bbd3b63c8c108e6a84b2d01f5e983f49d7cdf63ee3c4545c8
+EBUILD markup-0.7.5.ebuild 771 BLAKE2B ad4a9dc1289cba27a73ef76ed35a4608cb703065224e73404511632c12551b8716670f089283f152d5d0f1f5d46dac5d28c080d65fec535989795079d3916348 SHA512 94bb0daf5318ad09bc89df90972b1f247ae932300c4d3548785a929cd97a531b40e2a1999a35099ad3649b0722cbf9680fbc2a4bd6210a2c7aa00a03fa1e533c
+MISC metadata.xml 339 BLAKE2B 2cc964584a884b63522373a90e38a9521df07f66dd2e610a2265946424af32509a815bd3dfb94272fca4e9fd2da2cba6c8b39b7f24af366754e2ea5b7c19d831 SHA512 6bfd336707285ff31847e877573b2c63c1b45dcbc15793b0bf663922bf48b331e5a89b2cd0e98833017733844047f11ac21dd365ed62be8c0aa93da10b6e8bc2
diff --git a/dev-ml/markup/markup-0.7.5.ebuild b/dev-ml/markup/markup-0.7.5.ebuild
new file mode 100644
index 000000000000..66c1698789fe
--- /dev/null
+++ b/dev-ml/markup/markup-0.7.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="Error-recovering streaming HTML5 and XML parsers"
+HOMEPAGE="https://github.com/aantron/markup.ml"
+SRC_URI="https://github.com/aantron/markup.ml/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}p1"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-lang/ocaml:=[ocamlopt]
+ dev-ml/lwt:=[ocamlopt(+)]
+ >=dev-ml/uutf-1.0:=[ocamlopt]
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ test? ( dev-ml/ounit )
+ dev-ml/ocamlbuild"
+S="${WORKDIR}/${PN}.ml-${PV}"
+
+src_compile() {
+ emake
+ use doc && emake docs
+}
+
+src_install() {
+ findlib_src_preinst
+ emake ocamlfind-install
+ dodoc README.md
+ use doc && dohtml doc/html/*
+}
diff --git a/dev-ml/markup/metadata.xml b/dev-ml/markup/metadata.xml
new file mode 100644
index 000000000000..ecd1021328e1
--- /dev/null
+++ b/dev-ml/markup/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">aantron/markup.ml</remote-id>
+ </upstream>
+</pkgmetadata>