summaryrefslogtreecommitdiff
path: root/dev-ml/markup/markup-1.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /dev-ml/markup/markup-1.0.2.ebuild
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'dev-ml/markup/markup-1.0.2.ebuild')
-rw-r--r--dev-ml/markup/markup-1.0.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/markup/markup-1.0.2.ebuild b/dev-ml/markup/markup-1.0.2.ebuild
new file mode 100644
index 000000000000..65041afd6bac
--- /dev/null
+++ b/dev-ml/markup/markup-1.0.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Error-recovering streaming HTML5 and XML parsers"
+HOMEPAGE="https://github.com/aantron/markup.ml"
+SRC_URI="https://github.com/aantron/markup.ml/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-ml/lwt
+ dev-ml/uutf"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit2 )"
+
+S="${WORKDIR}/${PN}.ml-${PV}"