summaryrefslogtreecommitdiff
path: root/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild')
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild
index f10bf23e527d..575154be6047 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild
@@ -3,8 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit cmake-utils llvm llvm.org python-any-r1
+PYTHON_COMPAT=( python3_{6..9} )
+inherit cmake llvm llvm.org python-any-r1
DESCRIPTION="OCaml bindings for LLVM"
HOMEPAGE="https://llvm.org/"
@@ -82,7 +82,7 @@ src_configure() {
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
# also: custom rules for OCaml do not work for CPPFLAGS
use debug || local -x CFLAGS="${CFLAGS} -DNDEBUG"
- cmake-utils_src_configure
+ cmake_src_configure
local llvm_libdir=$(llvm-config --libdir)
# an ugly hack; TODO: figure out a way to pass -L to ocaml...
@@ -98,13 +98,13 @@ src_configure() {
}
src_compile() {
- cmake-utils_src_compile ocaml_all
+ cmake_build ocaml_all
}
src_test() {
# respect TMPDIR!
local -x LIT_PRESERVES_TMP=1
- cmake-utils_src_make check-llvm-bindings-ocaml
+ cmake_build check-llvm-bindings-ocaml
}
src_install() {