summaryrefslogtreecommitdiff
path: root/dev-ml/labltk/labltk-8.06.10-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-19 07:00:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-19 07:00:00 +0000
commitc5572b13d51970d6603acd131f27991cc1b66a79 (patch)
tree459c832fa5c0913b9ce0f85eed5e29922cc0425f /dev-ml/labltk/labltk-8.06.10-r1.ebuild
parent6e476156e1a0d2f4aa53968c37835c3441301367 (diff)
gentoo auto-resync : 19:11:2022 - 07:00:00
Diffstat (limited to 'dev-ml/labltk/labltk-8.06.10-r1.ebuild')
-rw-r--r--dev-ml/labltk/labltk-8.06.10-r1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-ml/labltk/labltk-8.06.10-r1.ebuild b/dev-ml/labltk/labltk-8.06.10-r1.ebuild
new file mode 100644
index 000000000000..ba2aeaa5b347
--- /dev/null
+++ b/dev-ml/labltk/labltk-8.06.10-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib toolchain-funcs
+
+DESCRIPTION="OCaml interface to the Tcl/Tk GUI framework"
+HOMEPAGE="https://garrigue.github.io/labltk/"
+SRC_URI="https://github.com/garrigue/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-warnings.patch.bz2"
+
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ~ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt X"
+
+RDEPEND="dev-lang/tk:=
+ <dev-lang/ocaml-4.13
+ >=dev-lang/ocaml-4.11:=[ocamlopt?,X(+)?]"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+"
+
+PATCHES=(
+ "${FILESDIR}/findlib.patch"
+ "${FILESDIR}"/${PN}-8.06.9-configure-clang16.patch
+ "${WORKDIR}"/${P}-warnings.patch
+)
+
+src_prepare() {
+ has_version "dev-lang/ocaml:0/4.11" && \
+ eapply "${FILESDIR}"/${P}-this-expression-has-type.patch
+ sed -i \
+ -e "s|ranlib|$(tc-getRANLIB)|" \
+ frx/Makefile \
+ || die
+ default
+}
+
+src_configure() {
+ ./configure --use-findlib --verbose $(usex X "--tk-x11" "--tk-no-x11") || die "configure failed!"
+}
+
+src_compile() {
+ emake -j1
+ use ocamlopt && emake -j1 opt
+}
+
+src_install() {
+ findlib_src_preinst
+ dodir /usr/bin
+ emake \
+ INSTALLDIR="${D}/$(ocamlc -where)/labltk" \
+ INSTALLBINDIR="${ED}/usr/bin/" \
+ install
+ dodoc Changes README.mlTk
+}