summaryrefslogtreecommitdiff
path: root/dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 02:49:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 02:49:59 +0000
commite53aa6b4fbe5a0c6db75d893829f7a6a37a14180 (patch)
treedd095d36490410a724fd271fcdf08c31a5336edd /dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.3.ebuild
parentc5ee568457ac776b65b71fa444e0dd47535bc44a (diff)
gentoo auto-resync : 28:01:2023 - 02:49:59
Diffstat (limited to 'dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.3.ebuild')
-rw-r--r--dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.3.ebuild b/dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.3.ebuild
new file mode 100644
index 000000000000..c4695cb9f924
--- /dev/null
+++ b/dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DUNE_PKG_NAME=lablgtk3-sourceview3
+
+inherit dune
+
+DESCRIPTION="OCaml bindings to GTK-3"
+HOMEPAGE="https://github.com/garrigue/lablgtk"
+SRC_URI="https://github.com/garrigue/lablgtk/archive/${PV}.tar.gz
+ -> lablgtk-${PV}.tar.gz"
+S="${WORKDIR}"/lablgtk-${PV}
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="3/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-ml/lablgtk-${PV}:3=
+ dev-ml/cairo2:=
+ x11-libs/gtksourceview:3.0=
+"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ dune build --profile release -p ${DUNE_PKG_NAME} || die
+}