summaryrefslogtreecommitdiff
path: root/dev-ml/gapi-ocaml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-13 07:36:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-13 07:36:05 +0100
commit5c0c70d5917e66743293789a6d6fd7d72250eb32 (patch)
treef6738b2393c696bb8b19bd6ff0e52aafadf65101 /dev-ml/gapi-ocaml
parentc5806fcd6b740ecbd62f4fb2e09d8c8dfa2966fc (diff)
gentoo auto-resync : 13:07:2022 - 07:36:05
Diffstat (limited to 'dev-ml/gapi-ocaml')
-rw-r--r--dev-ml/gapi-ocaml/Manifest4
-rw-r--r--dev-ml/gapi-ocaml/files/gapi-ocaml-0.4.2-ounit2.patch58
-rw-r--r--dev-ml/gapi-ocaml/gapi-ocaml-0.4.2-r1.ebuild33
-rw-r--r--dev-ml/gapi-ocaml/metadata.xml24
4 files changed, 119 insertions, 0 deletions
diff --git a/dev-ml/gapi-ocaml/Manifest b/dev-ml/gapi-ocaml/Manifest
new file mode 100644
index 000000000000..6cbc3774781d
--- /dev/null
+++ b/dev-ml/gapi-ocaml/Manifest
@@ -0,0 +1,4 @@
+AUX gapi-ocaml-0.4.2-ounit2.patch 1775 BLAKE2B 1e5bf19cf0adb559491c6ca9894d79bdff3fe6281d6a894b08f3fdc9576a2ba0b20ce5c7a72b620ca2592cbe76532227685fb8f7d6262dd095bab89d6fd68ff4 SHA512 98dc8a6481665ad3a4f89c7fc5879ef0161d165af7ee71651f2ee5eb2e5f789cde6b5461f870a478390c4198c322141164d6308c5b5c4c8f82fc37b39ef0b4f9
+DIST gapi-ocaml-0.4.2.tar.gz 466749 BLAKE2B 6a3e66618ed9a665de2892dc7657268f3bad43b871d6d761148152d61de2d988bc13b5051e39da4d1ddad0c620237c6018b87cd2303bc086c570aa879c197e4f SHA512 57d933c2d47ef7b80cb55b661f8df1b8642ff301d54f0fd1dfd4a9bc6238a4cb93a308e6918bbbc080fac146cf5fca2ccfe149d0528a63ead5e29e452c9cc427
+EBUILD gapi-ocaml-0.4.2-r1.ebuild 654 BLAKE2B 7a47627b86896d738c9e66152324ae67969be52b41f834de9fcd747af7584497baaf214ff86775567ffb840c89074323e51912e695834b0dc2280c0ca81225bc SHA512 04ba949fe16668d6a6d72737347aa1ff404dfadfba165209cf4d8ad0801cadc1b9bdf21cf187acc17f1e1f629cee5aa3fdf31594713b87d087fe74752130f1e9
+MISC metadata.xml 1046 BLAKE2B 4be6ad680be65ef85701c614caf80485cd68c7088358ce3b4ba201c3c4305630926cc0c4c3bb5c0d683a3ac2ba7c01463d9c5d0b281374bd8d32c1409a584ea9 SHA512 2ba3b944b84409512bca0bad76123719821f33666ebee5dbd1836baba1b7b67157b655bf6e13a9530e016cfa8c027398e98c3244405a6355f2c620e01e5583a3
diff --git a/dev-ml/gapi-ocaml/files/gapi-ocaml-0.4.2-ounit2.patch b/dev-ml/gapi-ocaml/files/gapi-ocaml-0.4.2-ounit2.patch
new file mode 100644
index 000000000000..36098d82ed67
--- /dev/null
+++ b/dev-ml/gapi-ocaml/files/gapi-ocaml-0.4.2-ounit2.patch
@@ -0,0 +1,58 @@
+diff --git a/gapi-ocaml.opam b/gapi-ocaml.opam
+index cb9b0fb5..923675d8 100644
+--- a/gapi-ocaml.opam
++++ b/gapi-ocaml.opam
+@@ -15,7 +15,7 @@ depends: [
+ "dune"
+ "ocamlnet" {>= "4.1.4"}
+ "ocurl"
+- "ounit" {with-test}
++ "ounit2" {with-test}
+ "yojson"
+ ]
+ synopsis: "A simple OCaml client for Google Services"
+diff --git a/src/test/dune b/src/test/dune
+index 5d955f42..ef45f0ce 100644
+--- a/src/test/dune
++++ b/src/test/dune
+@@ -1,7 +1,7 @@
+ (executable
+ (name testSuite)
+ (flags (:standard -w -3-6-23-27-32-33-50))
+- (libraries threads oUnit gapi-ocaml))
++ (libraries threads ounit2 gapi-ocaml))
+
+ (alias
+ (name runtest)
+diff --git a/src/test/testSuite.ml b/src/test/testSuite.ml
+index 7851661e..150781f7 100644
+--- a/src/test/testSuite.ml
++++ b/src/test/testSuite.ml
+@@ -76,11 +76,11 @@ let build_suite_from_list test_list =
+
+ let _ =
+ let test_list = ref (core_tests @ model_tests) in
+- let ounit_specs =
++ let ounit2_specs =
+ [
+- ("-verbose", Arg.Unit (fun _ -> ()), "See oUnit doc");
+- ("-only-test", Arg.String (fun _ -> ()), "See oUnit doc");
+- ("-list-test", Arg.String (fun _ -> ()), "See oUnit doc");
++ ("-verbose", Arg.Unit (fun _ -> ()), "See ounit2 doc");
++ ("-only-test", Arg.String (fun _ -> ()), "See ounit2 doc");
++ ("-list-test", Arg.String (fun _ -> ()), "See ounit2 doc");
+ ]
+ in
+ let arg_specs =
+@@ -100,9 +100,9 @@ let _ =
+ ]
+ in
+ let _ =
+- Arg.parse (arg_specs @ ounit_specs)
++ Arg.parse (arg_specs @ ounit2_specs)
+ (fun _ -> ())
+- ("Usage: " ^ Sys.argv.(0) ^ " [-service svc] [-all] [oUnit arguments]")
++ ("Usage: " ^ Sys.argv.(0) ^ " [-service svc] [-all] [ounit2 arguments]")
+ in
+ let _ =
+ (* Reset argument counter, to let OUnit reparse arguments *)
diff --git a/dev-ml/gapi-ocaml/gapi-ocaml-0.4.2-r1.ebuild b/dev-ml/gapi-ocaml/gapi-ocaml-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..156be6ded14c
--- /dev/null
+++ b/dev-ml/gapi-ocaml/gapi-ocaml-0.4.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune findlib
+
+DESCRIPTION="A simple OCaml client for Google Services"
+HOMEPAGE="
+ https://opam.ocaml.org/packages/gapi-ocaml/
+ https://github.com/astrada/gapi-ocaml
+"
+
+SRC_URI="https://github.com/astrada/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="ocamlopt test"
+
+RDEPEND="
+ dev-ml/ocurl:=
+ >=dev-ml/ocamlnet-4.1.4:=
+ dev-ml/cryptokit:=
+ <dev-ml/yojson-2:=
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-ml/ounit2 )
+"
+
+RESTRICT="!test? ( test )"
+PATCHES=( "${FILESDIR}/${P}-ounit2.patch" )
diff --git a/dev-ml/gapi-ocaml/metadata.xml b/dev-ml/gapi-ocaml/metadata.xml
new file mode 100644
index 000000000000..550aa3b52af7
--- /dev/null
+++ b/dev-ml/gapi-ocaml/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription lang="en">gapi-ocaml is a simple, unofficial, OCaml client for Google Services.
+The library supports ClientLogin, OAuth 1.0a, and OAuth 2.0
+authentication. Supported RESTful APIs: Calendar APIs v3, Google+ API
+v1, Tasks API v1, APIs Discovery Service v1, URL Shortener API v1,
+OAuth2 API v2, Custom Search API v1, Google Analytics API v3, Page
+Speed Online API v1, Blogger API v2, Site Verification API v1, AdSense
+Management API v1.4, BigQuery API v2, Drive API v2, Drive API v3,
+Gmail API v1.</longdescription>
+ <upstream>
+ <bugs-to>https://github.com/astrada/gapi-ocaml/issues</bugs-to>
+ <remote-id type="github">astrada/gapi-ocaml</remote-id>
+ <maintainer>
+ <name>Alessandro Strada</name>
+ <email>alessandro.strada@gmail.com</email>
+ </maintainer>
+ </upstream>
+</pkgmetadata>