summaryrefslogtreecommitdiff
path: root/dev-ml/gapi-ocaml/gapi-ocaml-0.4.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 02:49:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 02:49:59 +0000
commite53aa6b4fbe5a0c6db75d893829f7a6a37a14180 (patch)
treedd095d36490410a724fd271fcdf08c31a5336edd /dev-ml/gapi-ocaml/gapi-ocaml-0.4.3.ebuild
parentc5ee568457ac776b65b71fa444e0dd47535bc44a (diff)
gentoo auto-resync : 28:01:2023 - 02:49:59
Diffstat (limited to 'dev-ml/gapi-ocaml/gapi-ocaml-0.4.3.ebuild')
-rw-r--r--dev-ml/gapi-ocaml/gapi-ocaml-0.4.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/gapi-ocaml/gapi-ocaml-0.4.3.ebuild b/dev-ml/gapi-ocaml/gapi-ocaml-0.4.3.ebuild
new file mode 100644
index 000000000000..3b7a8af6966d
--- /dev/null
+++ b/dev-ml/gapi-ocaml/gapi-ocaml-0.4.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune findlib
+
+DESCRIPTION="A simple OCaml client for Google Services"
+HOMEPAGE="
+ https://opam.ocaml.org/packages/gapi-ocaml/
+ https://github.com/astrada/gapi-ocaml
+"
+
+SRC_URI="https://github.com/astrada/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="ocamlopt test"
+
+RDEPEND="
+ dev-ml/ocurl:=
+ >=dev-ml/ocamlnet-4.1.4:=
+ dev-ml/cryptokit:=
+ dev-ml/yojson:=
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-ml/ounit2 )
+"
+
+RESTRICT="!test? ( test )"