summaryrefslogtreecommitdiff
path: root/dev-ml/fpath/fpath-0.7.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/fpath/fpath-0.7.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/fpath/fpath-0.7.2.ebuild')
-rw-r--r--dev-ml/fpath/fpath-0.7.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/fpath/fpath-0.7.2.ebuild b/dev-ml/fpath/fpath-0.7.2.ebuild
new file mode 100644
index 000000000000..8a7ca78a2291
--- /dev/null
+++ b/dev-ml/fpath/fpath-0.7.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit opam
+
+DESCRIPTION="File system paths for OCaml"
+HOMEPAGE="http://erratique.ch/software/fpath https://github.com/dbuenzli/fpath"
+SRC_URI="http://erratique.ch/software/fpath/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-ml/result:=
+ dev-ml/astring:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/topkg
+ dev-ml/ocamlbuild
+ dev-ml/findlib
+"
+
+src_compile() {
+ ocaml pkg/pkg.ml build || die
+}